Bug Or Not?

Hi Im new to Blender and idrk what is the problem and why it always keep the setting lock up when adding new object
did i just press something thats why it was disabled? or is a known bug?


yes that load factory default setting can fix the problem
but its annoying that everytime it lock up for random time when im modeling
i need to restore its default factory setting in the setting in preferences like hotkeys plugin themes and etc …

is there a solution to this? please its really stressing me ;( …


I think it’s a bug, I started this thread a couple days ago:


@K Horseman: In my link above I ran into the same problem. It seemed to happen when installing/turning on a new version of Blender and the importing of previous settings. Not only did it shut off the Global Undo in the new version, it shut it off on my older version as well. I’m not sure if the OP has more than one version going on, and if they don’t, then it’s another issue altogether, although tied to something similar. :confused: 32-bit here

I might be wrong, but after resetting to factory defaults you still have to save the preferences to make that permanent, right?

It sounds like the OP resets the preferences but does not save that reset state as new default. Therefore all is well for that particular session, but on the next launch of Blender all is back to the faulty situation…

it shut it off on my older version as well

So, Vicky, you have 2 blender versions (2.71) in parallel?

I would suggest creating /config folder under /2.71 for each and configuring each then.
Configurations will be kept separate, not in the folder where they usually are stored (whatever was the place called on your OS - win for OP, anything else VickyM72 might have) overwriting one other each time you fire different ( but still 2.71) version.

@eppo: Right now I have 2.70 which I mostly use, and a 2.72 test build. Once I turned Global Undo back on, problem solved, and it’s working fine each time I turn on any Blender version I have, but, the problem is the Global Undo is getting turned off when grabbing a new version of Blender. We know how to fix it, and how to make it default, but why is it happening? It was a big WTF moment when I tried to add a circle and couldn’t adjust the vertices. :smiley: What’s even more strange is when I opened 2.70 to see if it was working OK since getting a new version, Global Undo was shut off in there too all of a sudden.

On your first startup of a new version install, you need to click the “keep previous settings” thing on the splash page. I can’t remember how exactly it’s worded, something like “keep previous settings” anyway. Otherwise you’ll lose preferences.

My user settings normally would have Global Undo on, so is it off in newer versions? I’ve never had only one version of Blender, and I instantly set the new ones to my own preferences, so I honestly don’t know what is default anymore. I might add that I only use ZIP Blenders(no installations), not sure if that makes a difference. I can’t recall this ever happening until the 2.71 series.

i think bug occurs when some plugin encounters error … see my post 7 for screenshot or can you test it like what i did … im using

mesh : loop tools … do some random bridges that is not really possible to do … so that error will popout and see if the global undo will turn off

Tested one more time on win pc where Blender had never been installed or unpack and run.

1st - download testbuild pack, unpack it in user’s home and run it, configure.

Blender is here: C:\Users\x estbuild-blender-2.71-48eac58-win32
Config folder gets created here: C:\Users\x\AppData\Roaming\Blender Foundation\Blender\2.71

Next, i download and unpack another 2.71: C:\Users\x\blender-2.71-8c3daab-win32

Config in C:\Users\x\AppData\Roaming\Blender Foundation\Blender\2.71 GETS OVERWRITTEN.

What i suggest is to create: C:\Users\x\blender-2.71-8c3daab-win32\2.71\config
and C:\Users\x estbuild-blender-2.71-48eac58-win32\2.71\config

As a result each 2.71 will have it’s own \config folder and it’s own settings. No other 2.71 will overwrite these; if there is no
…\2.71\config it will go to \AppData…

It is fine when there is only one 2.70, 2.71 or 2.72 but it gets dangerous when there are several of these present - if one gets some love from devs and this messes up something you easily run into issues.

Cons - you have to configure each separately - copy settings could lead to this type of errors.