BUG: Render+Anim doesn't work via button. Blend included.

When I render the model as a still it works fine.

When I push the animation button to render the animation, it only shows the background and renders each frame with it.

I check for locked layers and tried restarting, etc.

Using Blender 2.40RC

Somebody experienced the same?

Might help if you posted a blend.

But, one thing you can check is if you have Do Sequence turned on.

Please download the blend to try it yourself, with version 2.40RC.

I disovered the following and I think it is a bug :


When I press the “Render button” it even doesn’t render a still image.
I have to press the shortcut, F12 to render it.

When I press the animation button, it doesn’t render…
So, I need to know the shortcut for animation to start proper rendering.
as a workaround… but still it remains a bug if you ask me.

I will post this in the bug tracker if somebody can verify that it is indeed a bug.

render buttons work fine for me

Strange, because on my PC it doesn’t work as it should… I’m completely sure. I tested and tried everything.
(OS Windows XP)

Anyway I posted this as a bug also in the tracker.

I downloaded the file and I’m using 2.37a in Ubuntu and only F12 works - pressing render or anim renders only the background.

Thats weird.

Appending the scene to a new file fixes everything for me (WinXP, 2.40RC1). Also, you have some stray geometry on that object (front view, zoom out, on the top left in editmode).

I think you have found a bug. Log into the bug tracker (you’ll have to register for it) on www.blender3d.org include your description and blend file so that the developers can fix it. Somehow your .blend file has been corrupted. Importing the scene into a new file and turning the appropriate layers on fixes the problem in the meantime.


Thanks fore checking it. The problem is already logged into the bugtracker. Let’s hope they’ll be able to fix it.
I’ll try to use the workaround in the meantime.


I logged it as a Bug and this is the answer I got from Ton :

>Comment By: Ton Roosendaal (ton)
Date: 2005-12-19 15:27

Logged In: YES

This is an ancient issue… when you disable the “Lock” icon from a 3d window, that window gets it full own layer and camera settings, independent of layer.
To render the local window, you have to press F12 with mouse inside the window. Using the button “RENDER” will render the scene layers and camera.