Bug reports/usability issues

Ok, I’ve just started using Blender and I’ve heard how it has this “interesting ui” that’s very keyboard intensive and takes time to learn but you’ll love how productive you are when you get used to it blah blah blah. So I was expecting a steep learning curve and a lot of keyboard commands to memorize, sure. That’s no problem. But I wasn’t expecting some of the very basic usability issues that I would have expected to have been fixed way back in the 1.0 release. So I’m throwing these out to see if I’m somehow the only one who finds these things annoying or what. ( blender 2.31a, WinXP )

The main things I’ve noticed are:

  1. one-line textfields. Whoa! I can’t even select a range of text with the mouse in the one-line textfields! And many of the basic editing keys aren’t functional: home,end,etc. Apparently there’s no concept of a selection at all! How can this be?

  2. text editor (Shift-F11): better than the one-line text entries (at least there’s selection), but still things like ‘end’ and ‘home’ do nothing. And cut and paste with windows doesn’t work? That’s like 12 lines of code to get pasting text from the Windows clipboard to work.

  3. Filenames: On WindowsXP, blender keeps reverting to dos 8.3 filenames for some reason. For instance when I click on a .blend to launch it. If I go to save that file later, it thinks the name is somefi~1.BLE. Gross! I wouldn’t even know how to write C code that reverts to 8.3 filenames if I wanted to, I don’t know how Blender manages to do it.

  4. Console: using the actual system console is annoying (at least on Windows). For example when running blender full-screen you keep having to flip back and forth to see console output. The printfs should be replaced with some sort of more flexible logging facility, but as a short term solution, you can just call freopen() on the STDOUT and STDERR file handles to get the output to go some file (memory-mapped, perhaps) and from there slurp it into a graphical console in the UI.

  5. Prefs: I keep setting it to “Emulate Numlock” and it keeps forgetting. It doesn’t matter if I hit Ctrl-U or not. Nor is it remembering that I want it to be full-screen. Actually I don’t think the prefs are working at all.

I have to say Blender is really cool, and I was able to figure it out well enough in about a day to make some 3D illustrations (which involved generating some meshes using a python script I wrote to import matlab data), so that made me happy. It also made me happy that it was free. So don’t get me wrong, I think it’s quite a great little tool. The boolean ops didn’t work for me, but that I can understand. Getting boolean operations to work robustly on breps is not easy. But it boggles my mind that paste doesn’t work, and these other little things that really wouldn’t require that much effort to fix.

I downloaded the source code to see if I might could figure out a fix for some of these things myself, since it really seems like just an hour or two of coding would be all that was required to fix a few of these issues. But
maybe there’s something I don’t know? Maybe 8.3 DOS file names are so ingrained in the source code that no one has been willing to tackle the issue because it will entail a complete rewrite? Maybe text in a textfield can’t be selected because the president of NaN declared that it was better that way, and all the loyal Blender devotees believed him? Maybe I’m just wrong and pasting from the windows clipboard does work, I’m just using the wrong key?


These thuings are discussed at www.blender.org

end of the preamble

Cool, welcome!

Why do you want to select? anyway you cannot cut & copy…
funboard was talking of this some times ago…

It works, just different keys than you think of, RTFM
(Read the Fantastic Manual)

Yup, it should not, try to delete the .B.blend file… you are not
the first saying this but you are one of the very few.

And why are you in the need to go to the console that often?
Anyway Win XP taskbar is there, it is a click…

THis is the first time I hear

Hehe, thanx for compliments, but maybe you underextimate how difficult is to keep an application really multiplatform.

I’m pretty sure that 8.3 conversion id done by the OS (WinXP) who believes that Blender is a DOS app… Blender does not do that by itself!

Keep blending,


the dos 8.3 stuff has to do with file association in windows.
i never click on .blend files (i am using NC like filemanager ) but get them with open/reopen last within blender.
then filenames are ok.


and the fix (iirc) to the double-clicking giving 8.3 filenames is to:

go tools-> folder options (in any my comptuer window)
go to file types tab
look for (and select) your blender file type
click edit
select the default opening method
click edit
make sure that it has double-quotes “” around the %1
click OK or whatever till you exit those dialogs

my default blender opening action shows up as follows:
“C:\Program Files\Blender Foundation\Blender\blender.exe” “%1”

Great, that seems to have worked! (Although there were already quotes around the %1, but there were not quotes around the program name. After adding the quotes I tried to change it back to make sure that was the culprit, but Windows would not let me (because it couldn’t find a program named “C:\Program” . So it seems like that was likely to be the source of the problem.

Who is in charge of the Windows installer? Can we get that fixed?

Regarding End and Home, it’s been added a little after the 2.31 release IIRC. The equivalent was Ctrl-E (End) and Alt-A (Home). No really user friendly

Regarding Copy/Paste: Look in the header menus of the Text window, the hotkeys are written next to the commands.

As for fullscreen support, you can easily do this through the commandline arguments. Use “blender -h” to see a list of the different arguments.


Ok thanks… I see now that blender.org has it’s own forums and a bug tracker.

Well it’s just instinctive. I see 2 or 3 digits I want to erase and replace with other digits, I select them first, then type what I want to be in their place. I just find that a lot easier than tapping the del key repeatedly. Plus it’s just an annoying inconsistency. It may be one line, but shouldn’t its behavior be as consistent with the text editor as possible? Both are for editing text, why shouldn’t they behave the same way?

Hmm. Which FM should I R? I’ve looked at a lot of different documentation but haven’t found anything about this in particular. The menus have “cut” and “paste” options and Alt-C and Alt-V seem to be the keys for it, but they don’t work with text on the Windows clipboard, just internally. I think I did see something somewhere about editing the “.cutbuffer” file in /tmp/ in order to paste into Blender, but come on, that’s hardly a replacement for actually having working inter-application cut and paste.

Great! Thanks. Either that or changing the Windows file association thingy as z3r0 d wrote fixed it. I’m not sure which it was, but it’s fixed anyway!

It’s where the python script output goes. Clicking on the taskbar and alt-tabbing are not too terrible, but it’s still not the same as having the output appear inside Blender itself.

This one still doesn’t work for me, even after deleting .B.blend. :-?

No, I’m pretty familiar with the difficulties of cross-platform development, actually. The Blender folks have done a very nice job overall.

Anyway, thanks for the responses!

This :wink:

And those worked for 2.28, I hope noone changed them…


Yes, I agree that this is not very consistent with the text window. If someone could change this it would be nice, just one more little step toward a program that is more consistent, user-friendly, newbie-friendly, and ergonomic. But this is not vital, they are details. By the way if you want to delete all you wrote, type SHIFT-BACKSPACE, to move at the beginning SHIFT-LEFT and to the end is SHIFT-RIGHT, with these commands you can be fast too.

This is probably the FM that he spoke about: http://download.blender.org/documentation/html/x12861.html

The problem is that this documentation is not correct about everything, and blender is buggy too!

First for the documentation. You can see at the very bottom that SHIFT-CTRL-C or V or X are the windows buffer accesses. So they exist and they work very well! For working inter-application as you do, there is even a better way to do, but it’s not documented… If you open a text file with ALT-O, you can then reload it at any moment with CTRL-R, so you can work in your other text editor, save your file there, go to blender and do CTRL-R.

Now for the text editor bugs, the undo [ALT-U] and redo [ALT-R] are buggy, they sometimes add a line that didn’t exist or stuff like that. And the worst bug concerning text, is that there no way to enter special characters such as []{}^|¦# to the text editor if you don’t have a us keyboard layout [I use a CH_fr keyboard]. I’m even ready to send by mail a CH_fr keyboard to any coder willing to implement better support for such internationalization! :wink:

I really like it the way it is, the console window is always one click away in the task bar… I don’t think that it would be much more ergonomic if the output would display somewhere in blender’s interface. But again, if there is a coder willing to do that, blender would win a little of consistency and be a little more newbie-friendly.

Ok then if you have some time, please go ahead! I really mean it, because it’s always good to have coders that are meticoulous and have the sensibility of the detail as you have! Thanks for your feed-back, but you should pehaps make your suggestions in the functionality board mailing list that is here: http://www.blender.org/mailman/listinfo/bf-funboard


Oh yes, and I forgot something very important, baxissimo, I have the same creature that you have as avatar!! Comes from japan! :stuck_out_tongue:


Wow. Thanks a lot for all the useful info Gabriel. I had subscribed to the Bf-committers list, but at first glance I thought “funboard” was for just having fun, like idle IRC banter or someplace where blender folks could just chill out together. So I didn’t sign up for that one :expressionless: he heh. I just signed up for it now.

I downloaded the source code and started looking through it, and MAN it looks pretty tight, but no comments AT ALL. Yikes! There’s not even a comment to tell you what each file is for. (Seems like that’s an issue that has been discussed on the committers list, and they realize things like that are a big barrier for attracting new developers) Well anyway, I’m going to lurk on those lists for a while and see what issues people are discussing.

Woo hoo! Doomo-kun! But the avatar I see showing for you right now looks more like a silouhette of Kenny from South Park… Maybe you’re doomo-kun on another forum?

Thanks a ton again! I’m going to go do some Ctrl-Shift-C Ctrl-Shift-V repeatedly now until I get tired of how cool that is. :smiley:

Someone figured this one out. Here’s the bug report

I wonder if maybe it only affects Windows users who have set their %HOME% environment variable in Windows. Anyway, a workaround is to copy a .B.blend that has the prefs saved in it (like from Program Files\Blender Foundation\Blender.blender) to your %HOME% directory.