Bug with Defocus node?

Instead of using the Camera settings to add some Depth Of Field to my scene, I decided to use the Defocus node in relation to the Z-Value… Alas, the result is awfully blocky (and this is not a problem of zoom).


The result is fine with the Camera settings but I need to re-render every time I change the DOF settings. I would like to switch to the Compositor from now on… but not to get such a poor result.

So, I’m wondering if there is a bug floating around. (I’m using the very last r57816 from the Build Bot on Linux, 32-bit. My test with r57299 wasn’t any more successful.) I checked the Bug Tracker and I found something similar reported last year but it’s already marked as “Fixed”. Are my settings insane? (I don’t think so…) Should I use a workaround? (I already have an idea.) Any advice?

Other pertinent data: In the Performance panel, I used a chuncksize of 256x256, OpenCL, two passes. (I played with all these settings as well as those from the Defocus node with no improvement.) I don’t think it matters but all this happened with Cycles on GPU.

Have had big problems too! Bartek Skoropa suggested blur the Z for this I think…

It is an old bug and it has never been fixed as far as I can tell. So implement your work-around and continue on.

Thanks everybody for pulling this thread out of its grave… :wink:

@BartekSkorupa: That’s the solution I found too: To use mist (once it was implemented). :smiley: