Buggy behaviour

Hello
I installed Blender for Windows (both 32 and 64 bit) and it acts really strange. It isn’t smooth, it flickers a lot and for example if I want to select an edge in edit mode I have to zoom in/out or do something to update the view. It feels like a cheaply coded software (which I know it’s not)
Any idea what is going wrong?
Thanks

maybe your computer cant handle it?

Try this, when you have loaded Blender , click there :
http://i.imgur.com/MQzB3.jpg
In the drop down menu that will open, select “User Preferences”

Click on the System tab
http://i.imgur.com/DbAaw.jpg

Click there now on the button under “Window Draw Method” and change the default Automatic to one of the choice (Full, Overlap, Overlap Flip, Triple Buffer)
http://i.imgur.com/L9rGr.jpg

Once done, click there in the bottom :
http://i.imgur.com/MGKq7.jpg
And in the drop down menu change it to “3D View”

Now use Blender, if it flickers again, redo what you have done, and change to another Window Draw Method.
If you find one that satisfy you, once you’re back into the 3D View, click on File then on Save User Settings so next time you’ll load Blender it will be already setup with your custom Window Draw Method.

If all of them fail, you can try to download the previous big version of Blender, that used different python, code etc… and may then load better on your system and graphic card, Blender 2.49b
http://download.blender.org/release/Blender2.49b/

It feels like a cheaply coded software (which I know it’s not)

You know, technically it is very cheaply developed software - most of the coders didn’t take any money for it…
Could it be that you are using Intel graphics? Those feel to developers like cheaply engineered (and manufactured) hardware…
But yes, try what Sanctuary suggested and if it doesn’t help: Report a bug

Thanks Sanctuary!
I did a bit of fiddling and it works ok now.