Bugs with OSX version...?


(Gr8RedShark) #1

Hello all! I’m an old hand at 3D, but Newbie to Blender. i’m using the OSX version with Mac OSX 10.1.4 and have run into what look like some bugs, althouh the interface is so bizzare I’m not really sure…
I thought I’d post this for all the other Mac OSX users to see if they’re getting it too.
First bug is occasional and apparently random crashes where the program just quits. It’s happened twice today, once when I tried to delete a Curve, and once after I had deleted some curves and tried to go back to Edit mode.

Next bug is I have trouble getting into Edit mode after I render. I do the following:

  1. start Blender.
  2. add a cube using the SPC key and the popmenu.
  3. add a lamp using the SPC key and its popup menu.
  4. render by hitting F12.
  5. hit ESC to put the render windo to the back and bring Blender to the front, then click in the Blender main windo to make it active again.
  6. try to go to edit mode by alternately hitting TAB or clicking the button.
  7. repeat above step many times before getting frustrated and quitting and posting on this forum.

Did I do something wrong? It might just be a problem of trying to figure out the OSX equivalent of Middle-Click or something…
any help would be MUCH appreciated


(digitalSlav) #2

if you are using 2.25 the cause could be a bug that persists in all versions i beleive. sometimes the controls get fudged… an easy fix is to do a spatial rotation (rotate view) then try tab again. if you run into this often you might want to try an earlier version.


(VelikM) #3

Try clicking on the top of the blender window to make sure the window has the focus, some times the focus stays with the render window. Just clicking inside the window doesn’t always work, so you have to click on the title bar at the top. It make it seem like blender has locked up.


(CurtisS) #4

I have found that OSX Blender does not like to run maximized. I get lock ups (it seems) when I do that.


(TGVoz) #5

Instead of pressing esc click in the Display Buttons window (F10), then move the cursor through te variuos windows you have configured making sure that the variius buttons “light up”.

Works well for me.
TGVoz[/quote]


(TGVoz) #6

If you do forget and press esc then activate the Dock in OS X and launch anything, I usually click on the Finder. Return to Blender via the Dock and all should be well.

TGVoz


(Gr8RedShark) #7

thanks all!

Yes when I am using Blender I make sure I click on the title bar of the main window to make sure it’s active and yes I make sure all the buttons light up, and no I do not run it maximized(full-screen). The only way to get back to edit mode is usually to add a new object, or Command-click on an existing object (not sure wht the CMD-click is in 3-button terms).
I think maybe that first reply was right, about a general error in publisher 2.25 (which is what I’m using).

tmtechie, where can I get an earlier version that is missing this bug, and what will I lose by going back?


(CurtisS) #8

This previous version was REALLY beta and rendered without OSA. You are better off with 2.25.


(digitalSlav) #9

yup - id stick it out most likely until the new version. don’t think you will miss much than what was stated but if you turn on the multi smesh function for the render state it will completely crash out the earlier version on load.


(ATMantis) #10

I seem to be having trouble with the Mac OS X version as well, I’m running OS X 10.0.4, which maybe why I’m getting these and your not, or I just haven’t got the idea of Blender yet :slight_smile:
Anyway, the bug I get is I carn’t select anything unless I press command + Tab, which will also change which application is active, which is not what I want, and another bug I’m getting is that I carn’t use any of the keys (like pressing E to extrude for example).


(Enos Shenk) #11

Yeah im using 10.2.1 and 2.25 runs like horrible crap on here. But 2.25 runs like horrible crap on my pc on win9x, win2k, my friends dell, his work machine, and another friends custom built winxp.

Im just praying someone fixes all these errors bug and graphic glitches in the next version. Ive got an addiction to feed for gods sake.


(Gr8RedShark) #12

Hey ATMantis,
first thing: Blender is damn weird!
second thing: it’s not hard to get used to. been using it for a week an already feels quite comfortable.

To select things (even on the OSX version) press B to uise the Box-select tool. then draw a box around what you want to select. If none of the keys are working, It might mean that the Blender main window is not the active window. Are you getting a problem where half of the window is beyond the top of the monitor? I get around this by changing the screen resolution, dragging the Blender window to a more reasonable location, and then changing the resolution back. It’s a hassle, I know, but it works. There’s also a way to do it from the command line, in Terminal. use the -p option and then 4 numbers, or use the -h option for help.
hope that helps you, man!


(ATMantis) #13

Okay, I’ve checked and Blenders window is the active window, and still the keys don’t work (not even space bar), and is having to press command + tab the only way to select menus or am I just doing everything totally wrong? I’ve tried tutorials, get about one paragraph in until what it says for me to do just doesn’t work… most frustrating.

I intend to get Jaguar soon, so when I get that I’ll see whether things improve, because I’m fairly sure it has to do with the fact that I’m using a very early version of Mac OS X which not even Quicktime works in.

Well thanks for the advice anyway, I’ll have to play around with it some more sigh.


(Enos Shenk) #14

Im using Hos’ and some other guy (i keep forgetting his name argh) custom CVS build. It runs great, but i still cant make the window bigger. Bah. Anyway Hos says use a -p flag to run blender with a border so i can resize it, but im rather new to OS X. How do i run this from terminal so i can give it a -p flag???


(Gr8RedShark) #15

The Terminal program can be found in your Utilities folder. launch Terminal an you’ll get, well, a Unix terminal which you can use to run your Mac (if you don’t like the finder). Use cd to get to the directory in which Blender resides. then cd once more into “blenderpublisher.app” and try Contents/MacOS/blenderpublisher -p 10 45 775 510


(ATMantis) #16

Yep, to move into a directory type (for example) cd /applications/blender2.25/, that would open up the blender2.25 folder assuming its in the applications folder. Hey Enos Shenk, you said you use a custom build? where could I get this custom build? Would be interesting to see whether I get trouble from it.


(secundar) #17

http://blender.dragonlight.fi/