Bugs with shape keys? (Now with .blend)

Is it possible to assign two different shape key ipos to two separate actions?

When ever i try to do that action number two just copies the shape key ipos from action one. If i delete/modift those it also changes the shape key ipos in the first action.

I hope that made sence :wink:

The user interface also gets buggy when working with shape actions, as you can se below the names in the action editor overlaps each other.

http://img216.imageshack.us/img216/5748/blenderebuglv8.png

Is all this known buggs, or am I just doing things the wrong way?

Don’t see it in the bugtracker:

http://projects.blender.org/tracker/?atid=125&group_id=9&func=browse

Did you duplicate your mesh? The Action should have only 2 users (the Object and the Fake User), yours has 4. Look in your Outliner window to see if you can find what else it’s linked to.

%<

I don’t think i have duplicated the mesh, but i am not shure. I think the number of users are correct, nla editor, the mesh, and the armature.

You can download the .blend here:
http://uploader.polorix.net//files/138/The%20final%20edition%20-%2013%20-%20experimental%20.blend

:slight_smile: Greetings,
I downloaded your file, and I saw your action editor has your shape key sliders and your bone markers at the same time? I don’t understand the names of the actions, but I had no problems adding actions that are listed into the NLA, but I didn’t find seperate actions for the shapes. I thought you were supposed to set these up seperately as individual actions, then commit them to ipo as shape type and then they could be inserted into the nla after you break the link to the user. I hope you understand what I am saying - I will try to get something worked out over the weekend that will show you what I am trying to say.

Craigo

Thank you for helping :smiley:

I have have tried both having the bone markers and shape keys together, and in separate actions. No mather what I do I can’t get two actions with different shape keys. If I a try to make a new action with shape keys, it replaces the old keys with the new.

Have you tried clicking on the action icon that’s next to the Ipo’s name in the Ipo editor to turn it off?

I think that should fix it.