Build errors with scons_1.1.0 ?[SOLVED] (...for me at least..)

Anyone else having build problems?

Ubuntu 8.04 64 bit
scons_1.1.0-1.noarch.rpm converted to .deb with alien

Error:-

Compiling ==> 'util.c'
source/blender/imbuf/intern/util.c:67:29: error: ffmpeg/avdevice.h: No such file or directory
scons: *** [/home/organic/build/linux2/source/blender/imbuf/intern/util.o] Error 1
scons: building terminated because of errors.

avdevice.h does seem to be missing.

try svn checkout again to overwrite previous files and scons again.
I’m not really having trouble with compiling blender but rather, using it at all on Ubuntu Interpid Ibex.
It’s Transparent! X(

Ouch!
I decided to wait a couple of weeks before jumping, to see what, if any, bugs emerged. Then thought I might just stay with Hardy as it is an LTS release and will be supported longer than Ibex .

I tried cleaning, then a new checkout, but got the same error. I tried downloading avdevice.h from trunk and saving it to ffmpeg, but received a bunch of new errors.

I take it you tried disabling compiz?

That happened to me when I first tried the blender version included in the Big Buck Bunny dvd, and with some other versions I don’t remember now.

The way I solved it was by overwriting the .B.blend file and .blend directory in my home directory (hardy heron has 2.45 in its repositories, don’t know about intrepid ibex) with the newer ones.
Hope that works for you.

Error is not related to scons.
http://lists.blender.org/pipermail/bf-committers/2008-October/022095.html

I suspected as much.
It looks like steps are being taken, I guess we will just have to wait it out.

Thanks kidb

I think they fixed this already, compiling works for me now.

Ubuntu intrepid, 64 bit.

same problem with scons 0.97 ubuntu 32

scons: Reading SConscript files …
ImportError: No module named Variables:
File “svn/blender-svn/blender/SConstruct”, line 42:
import tools.btools
File “svn/blender-svn/blender/tools/btools.py”, line 6:
import SCons.Variables

squareline, you may need to update scons:-
http://www.blender.org/forum/viewtopic.php?t=13928

Update - Alas it’s still broken for me on Hardy

.

in cant find scons 1.0.0 in synaptic package manager after reload package info. How can i update?
and seems for others updated to 1.0.0 but have same problem.

It isn’t in the repository, you can get it here:-
http://www.scons.org/download.php

I used alien to convert the .rpm tp .deb but as far as I know it is fairly straightforward installing the .zip or .tar.gz(though I have not tried!).

oh Thank you, scons woks agan, i converted rpm to deb :slight_smile:

I see that avdevice.h was added today, so that should fix the compilation error.

Umm, not entirely. Presumably it fixed that problem but I still get errors. Here is an excerpt,

source/gameengine/VideoTexture/VideoBase.h: In function ‘void Video_init(PyImage*) [with T = VideoFFmpeg]’:
source/gameengine/VideoTexture/VideoFFmpeg.cpp:612:   instantiated from here
source/gameengine/VideoTexture/VideoBase.h:166: warning: deprecated conversion from string constant to ‘char*’
scons: *** [/home/organic/build/linux2/source/gameengine/VideoTexture/VideoFFmpeg.o] Error 1
In file included from source/gameengine/VideoTexture/VideoBase.cpp:30:
source/gameengine/VideoTexture/FilterSource.h: In member function ‘virtual unsigned int FilterYV12::filter(unsigned char*, short int, short int, short int*, unsigned int, unsigned int)’:
source/gameengine/VideoTexture/FilterSource.h:199: warning: suggest explicit braces to avoid ambiguous ‘else’

…it goes on.

Could it be something I am doing wrong?
Builds fine without the game engine.

Ubuntu Hardy(still…)
gcc-4.3
64 bit

Content to wait, but if it is my own stupid fault I would rather find out sooner.

Maybe this is it here?

[email protected]:~/blender$ svn log -r 17269
------------------------------------------------------------------------
r17269 | ben2610 | 2008-11-01 15:42:03 +0000 (Sat, 01 Nov 2008) | 1 line

Video Texture: remove support for capture device, the linux ffmpeg repository is not ready yet.

On Interpid, if I do scons update, (0.9.7 or something) all it says is it’s already new!
I GET FROM HERE NOW!

Why did you use the rpm and not the Debian package directly?

Martin

I had a hard time finding any SF mirror that actually had the deb file, so I had to google the file name. Grabbed one from here.

Woah!
I didn’t see that link, I only read the big writing. The debian link is coming up 404, I’ll keep trying.

It was mainly for convenience. Having had time to read the install instructions, it seems there is only a single directory installed, but I didn’t want the potential hassle of chasing up where it installed to. A .deb is much simpler to remove, so I converted the .rpm to play with.

Did I do wrong, it seems to work? (…some…)

I get this when I try to compile SVN as of this post time and date:

C:\build\blender>call scons BF_TOOLSET=mingw BF_BUILDDIR=c:\build\builddir
scons: Reading SConscript files ...
ImportError: No module named Variables:
  File "C:\build\blender\SConstruct", line 42:
    import tools.btools
  File "C:\build\blender	ools\btools.py", line 6:
    import SCons.Variables
The system cannot find the path specified.

SCONS 1.1.0
windows XP SP3