Building Blender from CVS under Linux?

I want to build Blender from cvs under Linux, but I dont know how to proceed. What tools, aditional packages and other stuff I need to be able to make this? And how to proceed?

Sadly for Linux I cant find the latest CVS binaries, so I want to compile myself.

you need gmake, gcc, g++… search for these in your package manager…
you can also use scons but I cannot help you with it because I do not use it.
Some distris do not install the “developement files” with every library. e.g. Suse does not and that means that all the header files are missing (and those are needed). You need to have a lot more things installed for building blender than for running it (that is my own experience).

My advice is, just get the sources, edit the *.mk files in the “sources” directory in the linux-sections to fit your needs (important thing is to insert the right python-version) and then just type make (or gmake) in the directory “blender”. It’s very likely that it will run for some time and if something does not work (e.g. a necessary library/header is not installed) the whole thing will stop and print the most cruel error messages. :smiley: Don’t be afraid then, just look at the first error-message. It’s very likely that this one is something like “could not find something.h” or “libsomething missing…”. Then you install the developement-files for the package and this package and it should work on the next run.
At least, that is my strategy :wink:

just try it and if you get stuck post your problem BUT PLEASE…

>>Post it in a support forum<<


If you’re on Ubuntu, you basically just need to download the tree and run scons (as I recall). If it don’t compile, just look at the error that it stops on… it’s probably a library failure then just search the package manager for the library and install until you get no more errors. I use to contribute Linux builds to from this method but, I’ve since gone back to Windows full time.

openSUSE here. Anyway, how to acces the CVS and make a local copy in my HDD? I have CVS and Cervisia but I cant figureout how to use them.

Googling “+cvs +blender” resulted in this link:
I just translate it from italian:

Accesso anonimo a CVS
È possibile fare il checkout anonimo di questo repository tramite il metodo pserver seguendo le istruzioni. Il modulo da utilizzare deve essere inserito come nomemodulo. Quando viene richiesta una password per l’utente anonymous, premere INVIO.
cvs -d:pserver:[email protected]:/cvsroot/bf-blender login

cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co modulename

Anonymous access to CVS
You can anonymously checkout this repository with pserver method. You need to personalize “modulename”
to specify what you want to download. When you’re asked a password just press ENTER.
cvs -d:pserver:[email protected]:/cvsroot/bf-blender login

cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co modulename

are you on Ubuntu or Debian?

“sudo apt-get build-dep blender”

he is on openSuSE as he mentioned above.
you do not really need to have cvs and it is a little bit difficult to handle for some since it runs on the command line but you can download a daily snapshot of the cvs either here (http) or here (ftp). Note that, since it is a snapshot it is not guaranteed that it will compile (especially during a stage of heavy developement… I already had snapshots with one or two small errors in the code)
But now (cvs frozen for new projects, only debugging as far as I recall) it should work fine.

good luck!

maybe this will help:


Thanks for your advices. Im downloading now the daily snapshot of the cvs from

What are the differencies between scons and make. Who is better to use. How to configure them to compile Blender? I dont know programming. The only think that I know about compiling is to write ./configure, make, make install in the source directory.

Ok. I figureout how to use scons. I hope!

I tryed to build the sources using this tutorial:

and also this:

But no succes! :frowning:

I edited the file: /usr/local/src/bf-blender/blender/config/ and changed the line: " WITH_BF_OPENAL = ‘true’ " from true to false, beacouse if is enabled, I get a lot of errors regarding to openAL. I installed OpenAL and all the asociated files using wikis tutorial.

Trying to compile I get a lot of errors regarding to “BPY_interface” and the compilling process is stoped. :frowning:

I have Python 2.5 installed on my system.

Also I tryed the qwequ777 metod. No luck. Same problem openAL.


SND_OpenALDevice.cpp:51:19: error: AL/al.h: No such file or directory
SND_OpenALDevice.cpp:52:20: error: AL/alc.h: No such file or directory
/usr/include/AL/alut.h:84: error: ‘ALboolean’ does not name a type

SND_OpenALDevice.cpp:754: error: ‘AL_POSITION’ was not declared in this scope
SND_OpenALDevice.cpp:754: error: ‘alSourcefv’ was not declared in this scope
SND_OpenALDevice.cpp:757: error: ‘AL_VELOCITY’ was not declared in this scope
make[3]: *** [/usr/local/src/bf-blender/blender/obj/linux-glibc2.5-i386/intern/OpenALSoundSystem/SND_OpenALDevice.o] Error 1
make[2]: *** [all] Error 1
make[1]: *** [all] Error 1
make: *** [all] Error 1


Any clues how to resolve openAL problem?

I had some similar fun in compiling the normal Blender on OpenSuse 10.1… I’d have to assume the CVS build would require a similar process.

Mostly what I did was go through the list of published dependencies

Once these were all installed (I found RPM’s for most all of them)

Setup scons on my system, installed openEXR, made sure I had the source to my main system.

Then ran scons. Each time It got a little farther along, and I just had to look at the log file and determine what other dependency I was missing.

Finally, after about a dozen attemps, it made it all the way through, and now I no longer have that annoying message on the console screen about not being able to find my python 2.4 installation. (And all that because gcc on OpenSuse 10.1 has an updated version)
I guess, what I’m saying is check over you dependencies, make sure all these have the sources too, not just the install (I made that mistake once in installing openEXR, and then forgetting to get the lib files installed… doh!)

Oh - And… just be persistent. You’ll get it compiled eventually.

Ok, just looked closer at your log excerpt…

" SND_OpenALDevice.cpp:51:19: error: AL/al.h: No such file or directory"

I think that means your missing the source for the OpenAL module… or the AL portion. For me, I fixed that by looking for OpenAL with the zen updater, picked the source files and let it install the source rpm’s

But, I suppose you cold go out and grab the sources directly from their site.

Hope that helps.

if openal ist installed (which very likely is the case) and it is not found then you have to edit the config.opts. You also need the developement files!! search for openal-devel in the package manager!

config.opts: there should be a line like
OPENAL_INCLUDE /usr/bla/bla/include

search for the missing *.h files in the /usr directory (It’s best to be root to do this…). If you find the *.h file, change the line in the config.opts. in our case - openal is not found - you have to change the openal_include line to

OPENAL_INCLUDE /<path_to_openal.h>/
OPENAL_INCLUDE /usr/local/include/AL

as it is on my SuSE 10.0 system (I think that it is maybe the same on SuSE 10.2)

if you cannot find the file it is very likely that the developement-package is not installed. You should find it on the dvd or whatever source you use - if not, look for a matching (version) openal-package on and install the devel-package from there.

You can do this with every error that says a *.h (header) file is missing. Find the corresponding line in config.opts *_INCLUDE and set the path to the header file. You have to do this quite a few times because SuSE has its own ideas where to place the include files…

hope that helps

While ago I wrote a little tutorial about Blender CVS compiling, maybe will help you, but it’s written for Debian based distributions. I had similar problem with OpenAL, quick solution was SCons with WITH_BF_OPENAL=0, read more about: