Building Blender Os X Lion

Hi,
I was building blender from svn on snow leopard and it worked fine, but now that I am on Lion, whenever I try to open blender, it says that blender cant run on my type of mac, and even though I am on lion and have the 10.7 sdk, it always says MacOSX10.5.sdk not available: using MacOSX10.6.sdk. I have posted a link to my user-config.py below.

Thanks!

user-config.py

you’re using scons right? had the same problem.

you need to leave scons, and move over to the better cmake/xcode build procedure. cmake is so much faster!

http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Mac