Building blender Scons problem

I`m following this guide on building blender http://mikepan.homeip.net/compileblender2

I`m at the point of compiling and the windows command prompt says scons is not recongnized as an internal or external command heres what i entered

cd c:/build/blender

scons BF_BUILDDIR=c:/install j2

I`m supposing this is a enviroment variables problem so what would i add to the enviroment variables to fix this

Here are my current enviroment PATH Variables

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\hp\bin\Python;C:\Program Files\TortoiseSVN\bin;C:\Python25;C:\mingw\bin ;C:\MinGW\libexec\gcc\mingw32\MinGW-5.1.4;C:\Python25\Lib\site-packages\scons-1.0.1\SCons

Anyone!!!

bump…

Just a suggestion, waiting 4 hours between bumps isn’t smiled upon.

With that out of the way, I’ll try to help.
First off, scons is a batch file located in the root of where python is installed (C:\Python25 for example),
is there an scons.bat file there?

No . bat file but TEXT File containing this > *a.0.1\SCons\Tool\sunf95.py
200 File Copy: C:\Python25\Lib\site-packages\scons-1.0.1\SCons\Tool\icc.py
200 File Copy: C:\Python25\Lib\site-packages\scons-1.0.1\SCons\Tool\ilink32.py

Full file would not fit

what is the TEXT file called?
also, if you’re using vista, did you install scons as an administrator?

scons-wininst and im on vista but i have UAC Off so i shouldnt need admin but i will reinstall anyway

EDIT: Re installed did nothing

I haven’t done it myself yet, but if you want to try a different method, you can look at this guide:

http://www.geneome.net/blender-tutorials/building-blender-with-msvc-using-cmake/

In the scons-wininst.log file, run a search for “.bat” to see if any batch files were made.
It should find scons.bat and scons-versionnumber.bat

I have this problem too but reverting to scons .97 fixes it any idea why?

Sorry i havent posted here in this thread for a while been busy but im doing the MSVC Building guide that was linked higher up in the thread getting the error python.h when building not found and i get the error even when i put the python.h file into the specified folders i have python installed to the default directory for windows C:/Python25

EDIT Fixed python.h problem new problem when buidling it says patchlevel.h not found there is no patchlevel.h anywhere on my system

I’m afraid I can’t help with the patchlevel.h problem,
but I’d suggest changing the title of your first post if you want to continue with cmake,
since then it wouldn’t really be scons related anymore and you might get more help if you update the problem.
You might also try what alienkid10 did and revert to scons .97 (this is also the version that I use)

i got scons working and compiled or tryed to anyway compile blender and i got some Great new! errors also there is no windows.h on my system
also i am using scons .97

Attachments


I got it to compile alittle more by copying every .h file from the windows sdk to the trouble directory including windows.h and i got the error could not find include file windows.h

is there some way to reference the windows sdk header files to scons?

Right now it’s compiling?(with scons) i hope and the only thing i have done is reinstall cmake and change the directories in VC++ To the right windows sdk ones? what happened that fixed it any ideas?

EDIT:It compiled alittle dissapointed i have no idea what fixed it?

Oh well