Building blender under linux


(Hannes) #1

Could someone help me with some instructions on how to setup blender under linux? I can’t find any instructions in the readme, and simply typing “make” won’t solve it.


(overextrude) #2

Ok…All you have to do is untar the archive (tar xzpvf filename). You only use the make/install stuff when you’re building a package from source code. Once it’s untarred, go into the blender directory and type ./blender. If you can get Blender running, and it starts behaving oddly, you may need to update the driver for your video card.


(pannomatte) #3

What distro are you using. If mandrake or Red hat Archiver is very easy.
Follow these simple instructions: (as root)
1 Go to your home directory right click in window. select “Create New:” select folder. Name it Blender.

  1. Go to the package you downloaded and right click on it. Open with Archiver. A window will pop up with the uncompressed contents of the file.

  2. Cleck on edit and “select all” they will be highlighted. Next go to Actions and select “Extract” you will be asked to extract a pattern, choose selected files or all. In the destination window select the Blender directory you just created. Then hit OK. and voila. If blender runs real slow or buggy and you downloaded the static version, try the glibc version.

If it’s still slow or buggy check your drivers and make sure they are Open GL compliant. If you are using a NVidia based chipset then you will have to update your drivers and follow this thread:
http://www.elysiun.com/board/viewtopic.php?t=632
and when you get it right you can download a bunch of demo files from my site here
http://www.aaaskywatcher.com/BlendArchive/

Blender On
Daniel


(Hannes) #4

Well, that’s about what I already tried, but when I try to run the binary file from GNOME nothing happens, and if I try to run it from the terminal emulator it says “cannot exectue binary file”.
What’s wrong?


(overextrude) #5

Could it be a permissions/ownership problem? Check to see that the owner/group is correct (you can set it using chown and chgrp), and the permissions should be set to 755 (you can change this with chmod)


(ZoltarX) #6

You might want to try the “Static” version first.

If the “Static” version works and the “dynamic” version does not, then try updating your video card driver as recommended by overextruded - or you could just keep using the static version if you don’t mind it.

Regards
ApplicatioNZ


(pannomatte) #7

Are you installing as root? What distro are you using…
System specs? driver card?
D?


(malefico) #8

That happened to me once when I downloaded the ALPHA binary instead of the x86 …
just guessing.

good luck.


(pannomatte) #9

For Red Hat 7.2 w 32mb Nvidia TNT PCI card I used
blender-creator-linux-glibc2.1.2-i386
The static version did not work for my setup. Ran S L O W
regards
Daniel


(Hannes) #10

I use Red Hat 7.1 on a PII266 with an ATI 3D Xpression+. Blender 2.22 static version.
If there was something wrong with permissions or system specs, wouldn’t I at least get an error message? I’m pretty sure I’ve tried running it as root, but I’ll try again to make sure.


(acasto) #11

I had a problem with the binary not running when I first started. Sorry I haven’t read this thread yet. What X server are you using? Blender requires OpenGL to run, for linux this would be the mesa libraries, are they installed? I was using an nvidia graphics card and it wouldn’t work either. So I downloaded the Nvidia drivers from nvidia and it works fine. Just watch out on some compatibility problems in some graphics configurations in the kernel. Such as framebuffers, they can cause crazy stuff to happend and segmentation faults.

I do beleieve the problem is probably in the X servera and libraries (as long as you have already check permissions, etc…)

Let me know how it goes


(VelikM) #12

Blender has always been a problem on ATI cards. Here is the most current information on xfree http://www.xfree86.org/current/ and for ATI cards http://www.xfree86.org/current/ati.html I seem to remember every one that had ATI cards having problems, in the terminal window it just says “blender quite”

To use Blender on linux you just unarchive the file in the dir you want it in, then cd to the dir that the blender binary is in and type ./blender to run. You don’t have to be root (unless you want to make a link to the bin dir, that lets you start blender from the terminal window by typing blender)

The most likely source of your problem is the video card.
.There was a lot of info in the Blender Knowledge Base on video card problems, the link is in the Questions and Answers forum area, it works, I just tried it.


(acasto) #13

To really narrow it down, find the version of your XFree86 server by:

rpm -qa | grep XFree

the go to www.xfree86.org or search google and check the status of drivers for your specific video card. Do you have mesa installed?

rpm -qa | grep mesa

If your video card is supported, you need to check it’s opengl capabilities and your opengl libraries on your system.