Building BVH - Nightmare

Just unpacked my new workstation to find it renders the Blender file I’d been creating on my laptop a lot slower than the laptop does (rendering with Cycles). It gets bogged down ‘Building BVH’. This is heartbreaking because although the laptop was a very decent mobile workstation when I bought it several years ago, this new Workstation is MUCH more powerful and cost me an absolute fortune. The file is identical so I don’t think it’s anything in the render settings. I’m hoping there might be something in the GPU settings I can adjust to fix this. I barely have time to see the words “Building BVH” at the top of the render window on the laptop whereas it’s there for quite some time on the render window of the new machine. Updated the M6000 driver but to no avail.

Laptop Specs:
hp Elitebook 8770w
CPU Intel Core i7-3840QM @2.80GHz 2.80GHz (8 threads)
GPU Nvidia Quadro K5000M
RAM 32GB
Win 7 Pro 64-bit

Workstation Specs: (slower render - believe it or not)
hp Z840
CPU(s) 2 x Intel Xeon E5-2687W v4 @3.00GHz 3.00GHz (48 threads)
GPU Nvidia Quadro M6000 24GB
RAM 128GB
Win 7 Pro 64-bit

Would appreciate any suggestions as to why this could be happening or even better - how to fix it?
Thanks.