Building EXTREEMLY low poly game but have run into some problems

blender 2.49b

please don’t critique my gramer, i am tired. my net books ability to run games is minimal so i am building a game for it. i am trying to add texture to the surfaces, except the uv maps arent working, they are making the meshes just white. my other problem i that i am using the “FreeLook.py” to allow me to look around, but if i link it to my character than i cannot move using the W,S,A, or D keys anymore, if some one could PLEASE give me very in depth clear vivid instructions on how to do it, instead of saying “click here, then here, then here, and boomm youre done” i cant follow’ that, im some what new to the game engine side of things, so help would be nice, also i keep falling through the floor if i look down to far, also, i cannot find anywhere a tutorial on how i can use an empty as a bullet, nor one that will show me how to make it so that when a sprite gets hit by the empty, it gets destroyd. if someone can give me detailed vivid instructions on how to do these things that would be AMAZING. ty so much for the help and once again excuse my gramer.

Upload the .blend file so we can know what you are talking about.

sorry for no sound, too large, also the freelook.py was a “invalid file type” so feel free to try and find it online, wasn’t hard, or if you have a better suggestion of what i should do, that would also be nice

Attachments


FPS.blend (396 KB)

Are you using Multi-Texture mode? If you have a netbook, use Multitexture mode, not GLSL mode. First, click the top-most menu in the Blender window - it might say “Blender Render” by default. Select that, and then select “Blender Game” - this will enable game-only properties that you can enable.

Next, to enable multi-texture mode, go to the Render tab (camera tab, on the right, usually), and then click on the Multi-texture button to switch to Multi-Texture mode. In Multi-texture mode, graphics aren’t as high quality, but it’s much easier on the GPU to render.

Once you’ve gotten Multi-texture mode enabled, you can either 1) use the UV-image to texture the object (when you Unwrap the object, assign the image you want to the object), or 2) use a Blender Material to texture the object (gives you a bit more control, like specularity amount, and multiple textures). You can use a Blender material by going to the texture tab and selecting the texture you want to apply - if you use this method, untick the Tex button on the face properties section (Edit tab).


i have multi texture on, all it is is solid shadless white

Okay, then is the texture showing up when you assign an image to it via the UVW-Image window? Also, are you sure that you’re in Textured game mode (the sphere button at the bottom of the 3D view)?

got it working, but can i add shadows at all? i meen, anything i uv mapped is just synched with the image, its not shaded, i would like shading too

In edition mode, go to texture face panel, there, select a face and click the button “light”, this will make it react on light sources (these must be on the same layer as the object to iluminate it). Then you will probably need to know that on this very same panel you will see a copy button that will make all faces have the same properties. Also you can set up if the face is two-sided and that can use transparency, or make a face work like a billboard.