Bump map in 2.37a and 2.41

I’m using Ubuntu Breezy 5.10 - when I render the following in 2.37a I get;

http://www.ironclub.net/blender/diamond237a.jpg

But with 2.41 I get;

http://www.ironclub.net/blender/diamond241.jpg

Anyone else get this? Is there a solution?

Looks like some kind of rampshader. I can’t really think of anything else.

Here is 2.37a without OSA;

http://www.ironclub.net/blender/noosa237.jpg

And 2.41 without OSA;

http://www.ironclub.net/blender/noosa241.jpg

Exactly same file (no rampshaders), open at the same time and using same configuration file.

IIRC, Ton was messing with some troubles with the Nor maps. Perhaps he hasn’t solved everything yet. Post in the bug tracker, and upload your blend file, it could be interesting for the coders, perhaps?

Cheers,
olivS

With the 2.37a version I installed it from the repos on Ubuntu whereas with the 2.41 version I simply downloaded the file and unzipped it.

If I run 2.37a from terminal I get;

[email protected]:~$ /usr/bin/blender-bin -w
Using Python version 2.4

If I run 2.41 from terminal I get;

[email protected]:~$ /usr/lib/blender-2.41-linux-glibc232-py24-i386/blender -w
Using Python version 2.4
Unable to load: libtiff.
Try setting the BF_TIFF_LIB environment variable if you want this support.
Example: setenv BF_TIFF_LIB /usr/lib/libtiff.so

So perhaps this is something to do with it? Perhaps if I replace the 2.37a installed files with the 2.41 components this will correct the problem?

Here’s the blend file.

Right click the link and choose to save to desktop.

http://www.ironclub.net/blender/kndiamond.blend

Could someone try it - open it and press F12 to render;

Do you get what I’m getting?

I’ve tried your blend file and what you need to do is change the texture filter to 0.1 .

That better but its just cut out the shading effect, its still not bumpmapping, just showing a pattern (2.41);

http://www.ironclub.net/blender/filter.jpg

Instead of this (2.37a);

http://www.ironclub.net/blender/diamond237a.jpg

  1. Turn off MipMap
  2. Set X- and Y-Repeat to 1
  3. Set Size-X and Size-Y to 30

Works in 2.41.

2.41 - much better than before

  1. Turn off MipMap
  2. Set X- and Y-Repeat to 1
  3. Set Size-X and Size-Y to 30

http://www.ironclub.net/blender/mip.jpg

2.37a - still better

  1. Turn on MipMap
  2. Set X- and Y-Repeat to 30
  3. Set Size-X and Size-Y to 1

http://www.ironclub.net/blender/diamond237a.jpg

In fact, this is what I would expect from your image texture. The black parts on the png File are quite large, so I think the bump map is correct that way.

Notice how with 2.37a that the bump map texture is detected with a much finer grain, whereas with 2.41 the bump map is detected as solid blocks like 2.41 can’t detect the full gradation of colours. It looks like blocks of grey rather than smoother silver.

Also notice that 2.41 detects the bump map as inverted, instead of little pyramids they appears as depressions.

I do see the difference. The normal maps are rendered differently in 2.4x, no question. Notice the lack of “correct nor map” in the textures panel.

Sorry for bumping an old thread but i have the exact same problem and it sort of pissed me off. I had an old scene that i rendered in 2.37a if i remember correctly. Now i was going to render a new version of it and fix some minor glitches but the bumpmap looked like crap. It was all flat and no small details were visible.

So does anyone know a solution to this problem or do i just have to use
2.37a again.

Thanks.

8/

jawdrop

does this mean that this never got figured out?, because I also have gone to 2.37a when I want my textures to bump more.did 2.42 fix it?

Turn off mipmap and interpol,set the mitchell filter on the render tab and set its value to 1.5(the more is high,the more is sharp).

thanx, I can’t seem to locate “mitchell filter”, is that only in 2.42?, or is that the “filter” in the texture window?, I’ve tried different settings w/ little results. I’ve got 2.41a…thanx again… johnd

Hi,
I just saw this thread. I meant to remember that Blender
uses Normalmaps instead of bumpmaps, now I see this.

So after all, Blender does support Bumpmap images directly?

I experimented with the file and by setting the “Normal” factor
in the “Map to” panel high enough (25 = max.) I can actually
see the bumps! Btw, the positive / negative effect you can
control by double-clicking the “Nor” switch in that panel
(such that the writing goes yellow, which means negative
effect. Then you have pyramids again instead of dents)

Best regards,
Michael

The mitchell filter is for antialiasing the entire image,is where the osa setting are located(in the render panel,try pressing F10)