Bump Map prob?

Blender 2.54 - Kubuntu 10.4 (The scene was made with Blender 2.49a where i’ve noticed the problem)

I’m trying to create a seascape for a project. I’ve created a sea water material with multiple layers of normal maps, i’ve applied it on a plane object but when i make a render of the scene there are some areas that they don’t have normal mapping:



These areas doesn’t appear on every angle:


Any ideas?

The blend file with the sea water material:

Not sure, exactly without seeing the blend file, but here are a couple of files to help you make an ocean/sea.

My bad, I did not see your BLEND file link. Maybe the problem is that you have stenciling enabled for the larger waves? I turned it off and could not see any anomalies in the render.


ocean_water.blend (157 KB)ras_wave_source_1a.blend (777 KB)

Unfortunately the anomalies don’t go away… But i’ve noticed something weird: When i rotated the plane by 90 degrees, the problematic area became smaller. Also when i disable the AA the anomalies disappear…