Bump Mapping

Ive read alot of things with bump mapping, but for the life of me, I cant seem to make it work! Is there a bump mapping tutorial or can someone explain how to use it? Thanks

It should basically go like this (correct me if I’m wrong):
Say you have a plane, and you want a groove, and a line ehm… sticking upwards. Just make your plane with all the material and UV images applied. Then you go make a texture for the plane. Fire up your favorite image editor, and make a new image of say 512x512 px. Resolution doesn’t really matter I think. Then fill it with 50% grey (R:127, G:127, B:127). Grey means neutral with a texture map. Where you want your groove, and the plane should go inwards, make a black line. Where you want to have a “bump”, make a white line. Black means negative, and white means positive. Then apply this texture to your plane. Go to the Map To tab in the Material settings. Turn off Col (unless you want a black, gray and white plane) and turn on Nor. Then you can play with the Nor slider to control how deep or high you want your grooves to be. The same thing can be done with spec maps or reflection maps.


Alright! Time to try it out! Thanks

I tried it out, and I think it worked, tell me if my texture was right?


It came out with a VERY thin line or two raised


Itll take some work i guess?

Your image is fine. Increase the nor slider in the map to panel to get more relief. Here is your bumpmap mapped to a cube with the nor slider set to 20.0


That was really helpful. I’ve been wondering about bumpmapping myself, but was a bit afraid to ask. All the documentation on everything is so…technical.
What would I do if, way, I wanted to make a brick wall, using an image of a brick wall as my texture image? Would I make a make a bumpmap under it with black lines and white “bricks” to bring out my wall texture and make it look real?

I think it looks fine. Have you turned OSA on? And you may have to click Extend on in the Texture buttons, otherwise it will repeat the texture.
If you want to have razor sharp edges, you’ll need razor sharp edges in the texture. Maybe because of the JPEG compression, there is a very small area between the colors in your bumpmap that uhm, blends those colors (I need to learn English.) That causes smooth transitions between the bumped areas, unless that’s what you want to achieve. Try next time to use TGA’s for textures, they won’t cause you to lose data everytime you save it.


That is the idea, but I would probably just take the picture of the bricks and convert it to greyscale (in photoshop or gimp) and use that – you would then also get the detail of the individual bricks. You can also enhance the bumpmap image by increasing contrast etc.

This link might help you, it shows the effects of the different buttons


What I would do (don’t trust me ;)), is create another layer on top of your brick texture in some 2d program. Then I would paint with some irregular brush black lines over the mortar. This will cause the bricks to “come out of the wall”. On top of this mortar layer you can paint with another irregular brush the bricks and small stones in the bricks themselves in white, to give the bricks some texture. Now put a 50% grey layer under the layers you created, and voila, a brick texture!
Bumpmaps don’t necessarily have to be painted, but it gives an extra bit of control. The brick texture could have been made by greyscaling the color texture and trying out some contrast and Levels tools, but it won’t work for every texture. Those tools don’t really know what the lower and higher regions of the texture are. You do, you have felt and seen a brick wall in real life.
Oh, and when painting is too much work, clone tools can do miracles too :slight_smile:


I LOVE you guys! :smiley:


Didnt quite come out right…? I applied the texture, turned on nor, and set the slider up to 20…

bumpmaps come out looking a lot nicer when you have antialiasing on (that ‘OSA’ button in your Render settings window) Also, usually the default value of 0.5 will get noticeable bumps. I’ve never had the need to come close to 20. if your bumps are that indented, its probably better to use geometry or displacement mapping.
if your bumps aren’t very pronounced, make sure your texture has high contrast (load it up in your image editor, desaturate it and play with the contrast)


I don’t believe that the texture is applied properly. If you set the texture to colour (col button) instead of nor you should see a picture of your bumpmap on each side of the cube.


It isnt… :frowning: guess I dont know how to texture!!

As of now I go to “Image” As the texutre… How do you do it properly?

What talion says.
My plane looked very much like your cube when it didn’t have anti-aliasing set on. Go to the Render buttons (F10), and under the big Render button there’s a button called OSA. Click it. Those little black and white lines on your cube are shadows and highlights caused by several surfaces being bumped up or down. They just look like black and white lines because OSA isn’t on.