bumpy fluid surface on obstacle

Hi everyone,

since a few days I try to fill an invisible cup with water. So I created a cup, used it as obstacle for fluid simulation and set it invisible for the camera.
My problem is the surface of the fluidmesh where it collides with the cup. It always looks very bumpy (see screenshot). I want a smooth, polished surface; like a crystal sphere.

Is there any way to reach this without setting the fluid resolution to a freaking high value?

The scene is set to metric units and everything is build in realistic sized.

Would be great if anyone got a hint for me. :slight_smile:
Thanks in advance,
Quen

Attachments


The calculations will always leave bumps the size proportional to voxels used for the calculation. after you bake, add on subsurf and setsmooth is the only way I know to smooth it.

I have not yet tried it, but you could set subdivision and smoothing to a high value in the panel, or if you already baked it, add subsurf and smooth modifiers.
hope this helps,
tillonius3002

Yeah, I tried both already. The smoothing option in the domain panel helps a lot, but still the surface is not nearly “clean”. Using a subsurf just sharpens the bumpy corners, but does not smooth it in a global way.

I tried a little more and found only one way that seems to kinda work: using the domain smoothing and a crazy high fluid resolution (600+).
This takes ages even for a few frames, but well… my computer does not need any sleep, right? :wink:

Thanks for your answers :slight_smile:

As you already stated, subsurf modifier will only make things worse. If you turn on subdivision in your fluid for particle generation, you will find the same problem.

The only way to fight this is maxing out the smooth parameter in your domain and using the smooth modifier after bake. You mast be careful with the smooth modifier, though. If you overdo it, you might lose too much detail in your final render.

I have followed Andrew Price’s advice (in his “realistic water” tutorial) of using a smooth brush in sculpt mode after applying the fluidism modifier with some success. Maybe that would work for you.

That’s only viable if you are working on a single frame render. Totally unworkable for animations, though. I can’t picture myself sculpting each single frame in a minute long animation. :smiley:

Try using a boolean modifier with a subsurfed copy of the cup.