Calling all rigging experts - Connecting mesh to existing animated skeleton in 2.56a

I have a project where I have successfully exported an animated dog from Maya to Blender. The mesh as an .obj, and the animated skeleton as a .bvh. The skeleton runs through all its animations fine. The dog mesh now merely needs re-weighting to the animated skeleton.

I select the skeleton, then the mesh, and then hit Control-P to bring the weighting options up. When I try to re-bind it, I get an error.

  1. Weighting the mesh to an armature is irrelevant, it is only animated bones. I have still tried it and the mesh does not deform with the moving skeleton.
  2. Weighting the mesh to bones gives me an error "No bones selected’ yet from the included snapshot you can see I have the bones selected.

It’s not an issue of order – I have selected the mesh then skeleton. Help!

It would be helpful if you shared your specific error that you get. Is “No bones selected” the only error you receive?

Are all of the bones part of the same armature? Are the bones in that armature enabled for deformation? Does the mesh already have an Armature modifier?

Yes, all bones are part of the same armature – which I assume is a hierarchy of just bones. (Forgive me, I am not a Blender user, but a Maya one). I simply needed to re-weight the mesh with the animated skeleton. Of the Blender tutorials I have followed, none have indicated a prepping of the skeleton itself for deformation. The mesh is a mere import of an .obj model, so it has no connections.

So when I try to rig the dog thus:

I get the error “no Active Bone” – but you can see I have it selected.

Ah-HA! I see where the problem is. By choosing Ctrl+P->Bone, you’re trying to parent your mesh to a specific bone. Since you’ve selected the Armature in Object mode (and therefore cannot select a specific bone; you do that in Pose mode or Edit mode), Blender doesn’t understand and errors out. Arguably, the Bone option shouldn’t be visible if you’re in Object mode, but let’s ignore that for now.

Instead what you really need to do is Ctrl+P->with Automatic Weights. That should give you the Armature modifier and automatically assign weigts to your mesh’s vertices relative to the bones that they’re close to.

Strange – I tried that too, to no avail. What are the odds I can send it to you for your expert eye to tell me where I keep flubbing up? I am sure it is user error.