cam displays wrong side of plane??

Hi everyone!
I am modelling a small forest scene and have now applied textures to my plane which will serve as the floor. The problem is, that after uv-mapping the Textures to the plain, the camera only displays them “from the wrong side” of the plane. In 3d view everything looks fine, the textures are displayed on the side of the normals. But when I switch to camera view (num 0), the plane is transparent. When I rotate the camera under the plane and view at it from the bottom, the textures are displayed correctly, but of course the z-coordinates of the terrain are inverted. I took some screens to give you an idea of what i mean:

This is what the camera shows (cam on top, normals oriented downwards):

This is the 3d-view from the side of the camera (textures obviously dont show, because normals are oriented the other way):

And this is the 3d-view from the bottom of the plane (now textures are visible, you can see the orientation beam of the cam from the other side sticking through):

I hope you understand my problem and can help me solve it. Every help is appreciated, as I am slowly losing my mind over this problem :frowning:

Greetz,
Grillmeester

Attachments




you need to flip the normals, editmode>F9> then select all faces and press “flip normals”
mTm

Hmmm…
I tried flipping the normals already, but when I do so, the problem is the other way round. Then the textures are visible from the top in 3d view, but the camera can only see them, when it is below the plain. Imo the 3d view behaves as it shuold, because textures are displayed on the side with normals. But the cam seems to be funny. It only displays the textures on the side without the normals…

3D objects are, by default, “one-sided.” A plane, by default, has only one “face,” and that’s the “front side.”

What you need to do is to set the plane to be two-sided and apply the texture to both of them. Or, use two planes… flip the normals of one so the plane “faces down,” then decorate both planes appropriately.

I think I was not able to explain the problem properly. Now I solved it by copying everything to a new .blend file. Everything works now, I probably just messed something up. But thx anyway for your effort :wink: