Camera Calibration using Perspective Views of Rectangles

Ow just noticd your last comment lol… i’ll try that one, think that might work :slight_smile:

Hello rombout. I think the focal length is around 25mm. :wink:

Also there is something fishy with the perspective of the “windows?”.

Well ill be dammed, yours looks spot on. Did you try the dev version 1 point perspective and what part did you use to align it with.

I tried the side of the cooker hood. Mine is okay but not 100% The thing is ihad found the model of this kitchen. But perhaps that is off. It doesnt match the camera at all. Yet when i start modeling from the view it sort of matches

Im almost 100% sure these are renders. I got a PDF from the builder and they all to clean, almost sure its 3d as well
See comparison

Cam calibration

Imported cam to main scene

But the model is a bit different as well. It looks about the same but the cooking area is different. Perhaps thats setting me off. Some parts look the same but differ a bit.

PS did you alter the camera afterwards? I got 32 35 cam, 32 for film height and 35 Focal length. When i adjust it to 25 foval it does matcg better already

I did some more checking on ref images i got. I cant remember from where i got the model. But its quite different in quite some spots. Guess its better to adjust the model to the image as well

That’s what I did with mine. Then I adjusted the scale based on a known object size, (I used the “bank foyer” picture above and put in a person sized object). Even though the focal length may be correct and the relative sizes, it could be the actual scale is out. So if you know say, the height and diameter of the stool, ue that as a reference, select everything else, (including the camera) and scale accordingly.

I used the dev version with 1 point perspective. I took the whole left wall for aligning. Maybe the ceiling can also be used for aligning. A larger surface area (longer lines) gives a more accurate result. My example is a little bit rushed, please take that into account.

Before I calibrated the camera, I did some descriptive geometry in LibreCad. Because the barstools are rotated relative to the other objects, I could find the “90° circle of view”. With this I created a guide-rectangle, like I did before in other examples in this topic. I calibrated the camera with this “help” image to find the focal length with “Solve Focal +Y”, this gave a focal length of 25.19mm.

Thereafter I used your original image and followed the procedure again with “Solve 1-point” with the left wall.

Because it was a bit difficult to determine the rotation of the barstool exact; the focal length can be a bit different, but not far from 25mm.

edit: if the ratio of the cooker hood (intersection cooker hood with ceiling) is square (is it?), then the focal length is around 24mm.

1 Like

I did some research again. The model was actually from Poliform, thats the brand which made that kitchen. Their 3d model they provided looks quite different than the image. I dont see any do with measurements. But some parts are kinda standard.

Yet also some items are quite of in proportions according to that image or render. So i guess im just to nit picky :slight_smile:

I had a bash with the same image and yep, mine came back 35mm. The scale was way off, so I slapped my generic “personsizer” in there and scaled everything up. It’s seems ok, but there are places it seems slightly off. Then again, given the POV, it’s not the clearest of images to work from, lots of surfaces almost “head-on”.

Interestingly, I tried another POV, (image below), using fSpy, it came back 49mm, however, in PVR it still came back 35mm, which makes me wonder if something isn’t right with my setup.

1 Like

I’ve tried attacking this a few times and I’m suspecting theres some sort of perspective control on the image. The lower rails on the glass area line up, but as you get to the top, if you apply a loop cut, the angle is very clearly off. However, the rest of the image is pretty close.

1 Like

Where can I find the PVR menu in the new 2.8 menu system?

Not, its still for 2.79 only. the main dev or someone else needs to convert it

Hi everyone

I have made some progress toward blender 2.80. You can check it out on GitHub. It’s on the blender-2.8 branch. You can find it inside blender under properties -> scene. The old style buttons are still there. Below, there is a new interface which is not working yet. Note that there are three icon images needed (inside the ./figures/ subdirectory inside the addon directory. You can generate them with the python script you find in that directory. You will need pycairo to do so, however. For this reason, I attach these images here. Please give me feedback about the plugin, if you can.

1-point 2-point 3-point


1 Like

This is a 2.5 minute tutorial on how to use this amazing Add-on !

Thank you
Port it to gentoo CG overlay

I like perspective thumbs!
Looks like it works!

@brothermechanic how did you get that to work? I did exactly as the install directions say (multiple times), but Camera Calibration PVR never shows up in the Scene tab like yours does…or anywhere else for that matter.

And @marcor you should probably update the 2.8 branch to reflect the UI changes.

please, install it by my ebuild

Will this work for OSes other than Gentoo? And if so how would I go about installing it? Just like installing other add-ons?

Thank you!

other than Gentoo will be harder
but you can read ebuild as instalation script

Hello, I am using windows and I still can’t install in Blender 2.8 from the 2.8 branch of the plugin :frowning: any progress on this?

thanks in advance.

hey the addon when i try to install it it doesnt installs!? i did the steps to install it but doesnt appears installed, i tried seeking by the name but nothing. i downloaded the 2.79 version EDIT: fuck i couldnt install from install addon from file maybe because blender doesn’t has access to overwrite their files in windows 7 i had to paste it to the blender addons folder instead, thanks in advance :P… and also why saids exactly 1 visible background required in top view, when there is already one in top view? and after a few tries shit happens, i did something wrong here?