Camera Fly Mode and a Parented Empty

I have what I hope is just a setting question. I have a camera parented to an empty that will not move when I switch to Fly mode (shift-F). If I clear the parent, fly mode works fine, but when I set the parenting back, the camera is stuck again. I can move the empty and the camera tracks fine, also I can move the camera with regular movement keys (g, r, and so forth). It is only the fly mode that has this problem.

I tried resetting to factory settings to try and clear any settings I may have screwed up. I also tried the same setup on a new project just to make sure it wasn’t something wrong with that particular blend file.
Another oddity, is that this problem only occurs on one of my computers. That computer is running Blender 2.6. I have a desktop with blender 2.58 (or 9, I cannot get to the computer at the moment). On that machine I don’t have this issue.

Is anyone running into a similar problem, or know if I just have something set improperly.

Any help would be appreciated.

Hi cdschuett

It’s to do with fact that the empty is the PARENT, and overrides the cameras freedom of movement.

The same happens if you apply physics to an object, and then parent that object to another object, that is not “physical”,(game engine), but in the physics case, you can add the physics to the parent and “pass” it to the child.

I do not see a workaround for “FLY mode”, as it is not designed to be that flexible, (though I could have missed something as well).

Why do you want to attach an empty to a Flyby camera? Maybe your goal can be realised using another technique.