Camera fly mode


I’m having a problem reverting to “normal” when exiting fly mode in 2.49. I can get it to stop fly mode, but when I try rotating around my object again, it rotates around the camera instead. What’s that trick please? lol. TY in advance - I’m sure it’s something simple - but I can’t figure it out. Any help will be appreciated.

so youre saying after you exit fly mode, rotating an object causes the camera to be rotated? :confused: sorry i didnt really get what ur saying, please clarify

Hi - ty for responding

Yes - for example:
When you first start blender you can rotate the default cube around it’s axis. However, after I exit fly mode, and go back to say front view, that no longer happens, now the camera rotates around the cube - or - sometimes around the other camera, it’s hard to tell sometimes which way it’s going for me. I also learned hitting shift/F allows you to fly that (default - non rendering) camera as well. However, it doesn’t revert anything back to the way it was either.

This only affects the particular window you use fly mode in - the rest are unaffected. So - I’m lost. Have any ideas? Anyone?

TY in advance

Yes, you’re still in camera view mode. Hit on your number keypad 1, 3, or 7 to change to front, side or top view. Then you can rotate around objects.

Hi Jennifer.

Yes, I’ve done that also - and the results are the same. I’ve also tried re-installing blender, and moving from 64 bit to 32 bit, on the off chance it was a 64 bit problem. Still have the problem. What I also don’t understand, is why the view camera rotates around the rendering camera, rather than the object itself after exiting fly mode? Does that help to better explain the situation? I’m totally lost here.

If the camera is still selected and you have ‘revolve around selected’ it will do this.
Is the cube or object selected?

It doesn’t appear to matter which one is selected, it stubbornly persists in revolving around the camera. Where is “revolve around selected” found? I’d rather my object revolve on it’s axis, but at this point I’ll take whatever works, lol.

It’s the rotational, scaling control here:

Hi again

sorry, that doesn’t appear to affect the camera rotation whatsoever. I tried every setting under there, and although it does affect the object center/scale/rotation point, as in transforming the object itself - it doesn’t affect the camera.

Sorry that doesn’t seem to do it either. That appears to only affect transformations to the object itself, not the camera. My other post appears to have gotten lost - lol, so I posted twice.

If you upload a blend file I can look at it and see what the settings are that may cause that.

Ty Very much - here’s a link: Up.blend

Okay, I went back and reread your post. I read too fast sometimes.
The blend file looks normal.
If I am in fly mode, stop by clicking, then click the MMB to rotate around, the view will rotate around the camera because the camera is still selected.
Be sure to stop the fly mode, then click either 1, 3, or 7 to get the other view.
Then select the cube (not the camera) your view should rotate around the cube.
Is this what you are doing?

Yes, that’s what I’m doing - but as you see - it’s not reverting to “normal” I still end up rotating around the render camera. I should add - I’m using 4/6 and 2/8 while attempting to get it to rotate - i have MMB as “pan”

Sorry, I’m out of answers on that one.
The blend file settings don’t appear to be causing it.

Ty for your help anyway :slight_smile: