Camera.. I dont get it

I’m trying to get the camera to show my object in GE but its a no-go, whenever I hit play it wont show my object… but if I look at the object from a custom angle and not the camera view and then hit play it gets drawn perfectly… what could be the problem here?

I tried tracking the camera to the object but it only shows the object when the distance is between 0.00 and 1.00, anything higher than 1.00 and its a blank screen… another thing I tried was to put a cube on the camera to see if it wizzes off somewhere far away as soon as the game engine is initialized… but that doesnt happen either so it means the camera just doesnt seem to want to display my object…

Have you tried to adjust the clipping distance on the camera?

The normals could also be facing the wrong way with the faces one sided.

no, cant be a location prob… the camera is facing directly onto a completly modeled Object that is lighted from every side… I checked the Camera Distance and it is about 3x as far away as needed… strange thing is it doesnt show anything in game engine, but renders work…http://img442.imageshack.us/img442/9813/0001ch5.jpg
http://img442.imageshack.us/img442/571/jufo0001yc4.jpg

Delete the camera and add a new one, maybe?!