Camera issues

So, not sure where else to put this so, here goes I guess.

So I only recently updated to Blender 2.78b, and I’ve been having a couple issues that I can’t seem to find solutions for anywhere, and I have no idea what’s going on.

I’ve been trying to model a city, which I’m still at a very early stage in and decided to set up the camera’s view for. The city, by the way, sits evenly on the X and y axis, by the way. However, when I either try to use the shortcut to snap the camera to view, or do it manually, I go to the camera’s view, which doesn’t change in the slightest, and the the city moves away from the origin and tilts around at odd angles.


The dotted line leads from the city to the center of the 3D space it seems.

Lastly, I tried to just move the camera itself itself into position, however it seems that no matter what I do, I can’t see ANYTHING with it. I’ve set it’s clipping to 4,500, and moved it to the point where it clipped into one of the coloured buildings and still nothing would show up in it’s view.

Try Alt-A?

No, all Alt-A seems to be doing is giving me a display of Blender’s FPS in the corner.

Alt-A in Object mode allows you to apply rotation and scale.

If you haven’t applied it, your coordinates will get screwed up in some cases.

Alt-A will start the animation and the number of FPS in the corner is how many frames per second the animation is running in the viewport. This is same as clicking on the play button on the timeline.

I guess what Anthony Forwood wanted to say is to use CTRL-A and then to apply the scale to the city.

Try to do it this way:
1.Press 1 on your keyboard(This will get you to the front view and then press CTRL + ALT + numpad 0(this will get the camera to your view, in this case the front view).

If the city is still not in the center then from the camera view press B and box select the whole city and put it in the center of your camera view. For this you’ll maybe have to go to the wireframe mode in order to select everything in the city.

Is your city one object or every building is separeted? Did you parent it to some empty or different object? Did you add some constraints to the model?

The dotted line from the center is an area light I think, so it shouldn’t affect the city.

You’ve not shown 90% of the important info in your screenshot.
Such as:
What camera settings
Have you changed any view settings in properties panel
Do you have more than 1 camera
Is the camera object set to be the active scene camera
And more …

Please always supply a demo blend file for review so we don’t have to guess all thee settings

So, I don’t entirely understand what exactly happened, but I guess I figured out what went wrong. In general, I used Open Street Map to generate the city in Blender, but when turning on the necessary addons, I forgot to turn on Import Images as Planes.

I opened up a separate file to do this again, and both issues I was having were fixed and just not present. The only thing that confuses me at this point is how the city appeared as an object that I can edit and everything in all the modes in any user view and still not be visible to the camera.

Maybe it’s because of the camera clipping. If camera was far away from the object, it will not appear, unless you changed the camera clipping.

I’m glad you figured it out :slight_smile:

Good luck with it :smiley: