camera stuck in fly mode

I have know idea what button i pressed, but every time I try to look through my camera I get this wierd dotted view as if it’s in flymode but its stationary, it completley ignores my real camera and instead only renders what the flymode camera sees, for the life of me I cant get my real camera to work, how do i get out of this? and yes i have tried the escape button

try selecting the real camera and pressing Ctrl+0

Often happens to me, too

Even deleting all cameras and adding a new one wont help

i had a weird camera bug the other day too, i would go into camera view, and my view was all at odd angles, but for some reason it worked fine in a different window. I think I fixed it by unsplitting the screen, to the good one, and then resplitting it after i had gotten rid of the offender. Another thing that would probably work is to open a new file, and append everything but the camera. If I get a file that’s too screwed up, that usually seems to work. new file > append contents of old file