Camera Trouble.

Good morning,

I am fairly new in Blender. I intend to use it as a more advanced architecture visualization software than Sketchup. I followed a basic architecture modelling tutorial, and I did not had any major issues… that is, until I tried to render the model. The model is all white, I still haven`t learn texturing in Blender; my problems are with locating the camera. Maybe the issue is that I am accostumed to Sketchup, which renders the whole window, without cameras.

They say a picture is worth a thousand words, so I`ll let the images do all the speaking.

In the first image I position my view in the scene I want to render. I “align the active camera to view” and I get the second picture.

The image gets heavily distorted and the “rendering square” is quite small, much smaller than what was intended. I tried changing the lens perspective, but that did not have any effect on the square`s dimensions. I tried zooming into the camera, but the only thing I accomplished was to get closer to the “square” (filling the entire screen): the square contents never changed.

The last image is the render. As you see, its very different from the first view, before the camera, the one I wanted to render. Its very zoomed in.

I`ve got no idea what is that big circle in the roof in the render either. But that is another problem.

Thanks for your help,

Attachments




In your second image just use your mouse scroll wheel to zoom into the camera view.
You may want to look at the ‘Lock Camera to View’ option in blender 2.58a
In the Properties panel (N) under View select the lock camera to view checkbox
Go to camera view (numpad 0)
Press the Home key on your keyboard to maximise the camera view.
Now you can move around just like in the normal 3d view but your camera will move to match the view and your render will be exactly what you can see as long as you stay in the camera view

Thanks for your response.

The “Lock Camera to View” is a really interesting feature, that will be of great use for me to position the camera, after modelling.

Now, for your first advice, this is what happens when I zoom in the camera. As you can see, the “square” gets larger, I zoom in the square, but so does everything else: the “square contents” remain the same, and there is no change in the final result. I must be doing something wrong?

Attachments



Scroll = zoom the view (not zooming the camera) = things get bigger in the viewport (not in the render). Do you want it to be small and difficult to see or large and easier to see. I don’t understand what is your problem ?

The render is made from the camera. Move the camera further back.

Alright, I`ve got it. With the “lock to camera” feature and Shift F I am able to precisely position the camera. Thanks!