Can a bad resource reference cause crash?

Guys… the same scene that has rendered without issues, now all of a sudden crashes my Card all the time (Vega 64 Open CL)… since I have appended a new model… I have tried to purge all the garbage resources and it worked … this one time… and now it keeps happily crashing on. The GPU performs nice on everything else, but when starting the resolving of the image/render it goes belly up every time, at different stages of the scene-build. I have loaded it into the 2.79b, 2.8b, nightly build … it does the same.
Driver is up to date.
PSU is more than what the system needs.
It renders more complex scenes without any problems.

Could a bad resources reference cause this?..

is there a checklist I can follow?


Try the new model in other software to see if it crash there and yes a model can become corrupted only with a very slight editing.

I once corrupt a model just by merging 2 vertex.

I switch recently to blender but in 3ds max i had access to advanced tools to see mesh integrity so maybe blender also have them but i don’t know yet.

Polynut, thanks for your reply.

The mesh seems fine… I have tried the non-manifold selection and it came out clean… there are also no verts hanging around disconnected, no doubles, or overly bugged planars,… in fact it is all triangulated, if that is what you mean.
Also materials are standard PBR … no weird node-compositions . I like to model my meshes as clean and auto-weight/rig-friendly as possible.

3d files can sometime play dirty tricks and often there is no easy way to pin point the exact problem.

Maybe you can send the file to someone with more experience in Blender.

People are very helpful here and i am certain one will probably chime in soon.

So… I’ve created a new Blend-File (empty) and appended al the objects within the old scene, also copied the settings , everything is 1 to 1 … and bang! It works.

This absolutely mystifies me.
I think there is a major ghost-resource-bug-glitch-thing (or whatever) going on.
Something loads that causes OpenCL to crash my GPU and the Driver-Software all at once