Can anyone explain these checkerboard shadows?

I’m very new to blender and I was working with a scene a friend gave me. It was a plain grass field and with some heavy tweaking and modification I made this dike and ditch. However the right bank of the ditch appears to be receiving some kind of checkerboard shadows which I can’t explain or fix. Can anyone help?



*Here is the blend file: https://docs.google.com/file/d/0B9rcAu5N0H7KbDFkdk9Gcm12V28/edit

Its hard to say.
Please post a .blend file if you can.

I’ve been trying to, but I can’t seem to get the filesize under 90MB, and the attachments only allow 15MB.

Remove unneccessary meshes/textures, use compress option when saving, or zip it. Stick file of Google Drive/Dropbox/Skydrive etc etc. There are plenty of easy solutions to be able to supply a file with just a little thought.

Removing the textured road and water meshes didn’t seem to do much as it remained a 90+MB file. I must be missing something as I can’t understand what would make it so big. Ultra compression brought it down to 16.4MB. Thanks for the Drive tip, handn’t used Goolge for fileshare before. Are people able to access the blend now?

https://docs.google.com/file/d/0B9rcAu5N0H7KbDFkdk9Gcm12V28/edit

Sorry for the bump, but maybe since I included the blend file someone can help?

It looks like you have 2 Sun lamps in your scene. This is not needed at all. Use only one unless you are explicitly controlling specular and diffuse with each lamp. Under the Sun lamp context increase and or play with Shadow Samples and Soft Size.

The second sun lamp is there to simulate the blue light from the sky which lights up the shadows.
Here is the result of removing it, and the checkerboard pattern remains:


Did you increase the samples and the soft size? Try setting samples to 9 and soft size to 90. Brighten the shadow color. You don’t have to use black. I usually set mine to 65% grey. If you want a little blue in your shadows you can even choose that as well.

By cranking up shadow samples and soft size you can get a Cycles style look using Blender Internal without the noise.

Attachments


This is with 9 samples and a soft size of 90. Rendering took almost 5 times longer and I don’t think the result looks much better than what I had before. 4 samples and a soft size of 10 looked better. Anyway, the checkerboard shadows still aren’t resolved, but thanks for teaching me about a Blender feature I didn’t know about yet. Will experiment with it further.


Well I finally found a way to fix it. When I applied the object subsurf and subdivision modifiers, then reseeded the particles, the checkerboard shadows were gone. Don’t know why that worked though.