Can Blender optimate an insane subdivided mesh to fewest triangles?

Hi! I have this very bloated mesh.[image|690x333]
(upload://dLNR4CCcG6r5zXNKjsAZWfUinlH.png)


I would like to have it triangularized, so the fewest possible triangles is used to build the mesh!
Is there a tool for that, and if so what is called, and in what menu is it placed / (what shortcut-key)

You can use Decimate modifier for it. Or just use Meshlab.

Thank you I will try and see if i can find the modifier ao meshlab

Thanks - i do get a less impressive result.


It may be because i use a plane(?)
My mesh-optimation seams to be ‘limited’ by all the uniform quads, so the triangles are forced to be identical in size. That is very different and better in your image!
I sub-divided 8 times -Maybe thats not enough, but i want to keep triangle-count as low as possible, and only 8 sub-divisions cause 200 triangles already, again because of the lattice of identical quads.
I did find the modifiers, but i have not found that ‘mesth-lab’-thing. I will try google :stuck_out_tongue:

there’s also a pay addon that can do this:
https://blendermarket.com/products/retopoflow

tho i think it’s a bit expensive for what it does ^^

ya, that pay addon is no option
…LOL meshLab is another program, not something in blender

Provide the blend file so people can poke at it.

Yes here it is. importedHeightMapForMeshBuild01_Plane4_8subdiv.blend (550.1 KB)
I have also found an AddOn Landscape, but i cant see any options to use a B/W shaded image of my own. Only the default mountain seams to be available.
If i could simply use my own geo-data-png,


that would be way better, than trying to overlay a quad-mesh with the heightmap generating B/W png.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

All I have is a simple plane in this scene, you need to embed/pack all the data necessary into the scene, plus send the original scene. We cant help you if you give us the wrong scene.

Okay. First of all, you’ll need to ‘Apply’ all the modifier that you used.
Seeing the provided screenshot, you still have, at least, your subdiv active but not applied.

Second, here is the result of the decimate with a plane scale 4 & subdiv lvl 8 as base parameters.

Non decimated mesh

EDIT: If you do need to have triangle only, you can combine Decimate with Triangulate.

2 Likes

Decimate, not Triangulate :unamused:

That is definitively better!
That could perhaps be low enough in vertices count!
And it looks stunning!
If i understand you correctly, i have added modifiers but they are not applied(?).
I have looked for a button but since i could not find one (poor eyesight im afraid…) i noticed that the mesh changed when i added the modifier, and hence thought that it was ‘done’.
I have to go back and study the UI better.

I understand that the png is not inside the file?
This is the file:


…mm I attached a .png, it says jpeg
I will zip the png, then
Aaroe Height Map (Merged).zip (324.1 KB)
Many thanks All, for your help!

Look at my first screen. At the top of the modifier ‘block’, you see two buttons, ‘Apply’ & ‘Copy’. When you use your subdivide & displace, click on thoose buttons (subdivide then displace).

Thank You!
I understand now. also that the sequence is important knowledge