Can I denoise AO pass?

I’m using the Denoise node and finding that only the Combined and DiffCol are being denoised. I’d also like to have a denoised AO pass, but it doesn’t work. I think I must be missing something. Is there a way to do this? I tried this set up, but it only seems to work for DiffCol, not AO.

What if you connect the other inputs into the denoise node attached to the AO output?

You need all 3 for it to work right.

Thank you, Sterling. That works for AO, but only if I disconnect the Denoise for the Image and DiffCol. Maybe it’s a clue in the right direction? It looks like DiffCol always looks good and doesn’t need to be denoised, so that’s good, at least. (btw, in my original post, I meant to say Composite instead of Combined.)

you can have multiple connections from your render layer node, just drag from the left end of the link to create a new link:

(note that I didn’t use the albedo on the AO denoise, it uses the color of the textures to discriminate the denoising, and I just want a smooth AO, so I only used the normal pass, try both and see what works for you.)

That works for the Viewer, but when render it and look at the AO layer in the output window, it still looks noisy, and when I import the output exr files into AE, the AO is still noisy.

That’s odd, are you certain you are getting the output file and not just the exr that blender spits out by default?

Can you do some other operation on the AO data to test? like multiply it by magenta and see if that shows up in AE.

You’re right, I added the magenta in the AO, but when importing into AE, it isn’t there, just the noisy grayscale one. The files are in the specified output location, so I guess Blender is overwriting the files output from the node system. Is there a way to keep Blender from doing that? Thank you!

Would anyone be able to explain to me if there’s any way to use the Denoise node to denoise all passes? It seems there must be a way or most of the passes aren’t useful. I’d love to be able to use this workflow. Thank you!

Something weird is going on here. I just tried denoising an AO pass and sending it to a file output node and it works fine on my side.

Maybe you can attach your blend file? You can delete the objects in it if you don’t want the scene to spread around, this is all about the render settings.

Thank you, etn249, I appreciate that. It suddenly got very busy and I’ve been swamped with work but as soon as the waters recede, I’ll be back and upload the file. :wink:

1 Like