Can I use Python 2.5?

Quick question: I’m using Blender 2.42a for Mac OS X on my Intel Duo iMac. When I installed 2.42a the docs (as best as I can remember) recommended using Python 2.3. I’ve got a couple scripts that won’t work with 2.3 and I want to upgrade Python. I notice that the latest stable version of Python is now 2.5, is it safe / recommended to install this? I also have the “Haloween” CVS version of Blender for OS X, can I use 2.5 with this? Thanks!!!

You have three choices on the download page:

http://www.blender3d.org/cms/Download.13.0.html

  1. Mac OS X PPC Python 2.3, 10.3+ (10.3 MB)
  2. Mac OS X PPC Python 2.4, 10.3+ (10.3 MB)
  3. Mac OS X Intel Python 2.3, 10.4 (9.0 MB)

So the only way you’ll successfully get v2.42a to work with Py2.5 is to compile it from CVS with 2.5 yourself.

%<

Thanks Fligh. I was pretty sure there was a reason I used Python 2.3, but it was a while ago and I couldn’t remember for sure. Guess I’ll just have to live without a couple scripts for a while.

Hopefully, when they build the final release version of Blender 2.43 for OS X Intel, they’ll use a more modern version of Python also.

Thanks again for your speedy answer!

Hi Fligh,
There does not seem to be a 2.3 version available for download. What would happen if you ran 2.4?

Kordo.

I just found this site. Hope this works.

http://homepages.cwi.nl/~jack/macpython/download.html