can MIPMAP be turned off per texture in the BGE 2.5?


I was wondering if it is possible to turn off mipmapping for specific textures, to create a pixel-like image. For example, I want a painting on the wall to show pixel-like, while I still want the wall to be blurring over distance (to prevent the glittering pixels) and use mipmap for the wall.

In the textures panel you can select whether you want that texture to use mipmaps or not, however, it doesn’t seem to do anything. Selected or unselected, the image still becomes blurry! Until I really run the whole blend without mipmap. This however results in the glittering pixels of distant objects and ugly low-res terrain textures…

How can I turn mipmapping off for only the painting or certain textures?

Ps, im using GLSL, and blender 2.58 x86 on windows 7.

Unfortunately, there isn’t a way to turn off mip-mapping for an individual texture in the current version of the BGE. However, it could be implemented from one of the GSoC (Google Summer of Code) builds - Kupoman was working on polishing the BGE. Hopefully, he got around to implementing this, as well.

use DDS texture format, with it you can make a texture without mipmaps

but you mipmapless texture will be filtered when you strech it…

so I think better you make a big texture with 8x8 pixels in it for example

Hmm… Would be nice if it could be implemented ofcourse! Since inserting a bigger picture will at least quadrupel its size… For small pictures or less demanding (more static) scenes its ok.

Hey all,

I was testing the new mipmap texture feature, i can turn back on the mipmap after it was off.

Another thing, it will be great if you could add a shader to solve the billboards artifact colision problem in the BGE.