Can you attach an extra bone afterwards?

Hi guys,

I have some minecraft characters in the file here, and need to put tools in their hands, which means adding an extra bone to the rig for the object, but I have no idea how to do it and cant find a tutorial on YT for this (which is where i learn to make the rigs). Can someone advise what the correct process for adding another bone is? I tried messing around trying to figure it out, but kept screwing up the model.

Scene attached:

HamishCharAssets.blend (1.01 MB)

Select the rig, enter edit mode, left click to set the 3d cursor at the location you want to create a bone, then press shift+a.

Hi there, i did try to do that, but when I am in edit mode with the armature selected, shift+a doesnt do anything, I can only add a bone when not in edit mode.

Ok just tried it and i can do that but what do i do next? i need to know the full procedure, as before I could set my physical suface into edit mode and also the rig so it was all “exploded” but now i cant, and i just have no idea what to do, i cant even reparent the things together as there is no longer a “with automatic weights” option in ctrl+p menu.

Ok so i’ve tried everything i can think of here.

  • I tried just parenting the tool object to the characters mesh and placing it in the “arm” box area. It didnt work, it only moves when the main “body” bone moves.
  • I CAN add a new bone to the armature in edit mode, there is NO shift+a menu, i have to duplicate an existing bone. But then, when I click the tool object then click on that bone, it selects the whole armature, not just that one bone, and in the CTRL+P menu theres still no Automatic weights option, so it will fail again, and just do like it did above.

If anyone can help or knows how to do this, please help, this is really holding me back now. If it simply cannot be done, let me know too, so then I can stop wasting my time. However if its not possible, I’ve already wasted enough already.

Doing stuff in blender is never really “wasting time”, because solving (and trying to solve) problems makes you better at solving other problems.

Anyway, you don’t really need a bone for this. Add an empty and a copy transforms constraint on the empty with the arm bone (Bone.001… you should name your bones) as a target, change the Head/Tail value to 1.000. Then, set the 3d cursor to the empty by selecting it and pressing shift+s and selecting cursor to selected. After that you select the pick and press shift+s again and this time choose selection to cursor. The pick should appear near the arm. Move it in place by moving/rotating it in object mode to “fit” the arm. Finally, parent the pick to the empty by selecting the pick first, then the empty and pressing ctrl+p. Then try rotating the arm.

Ahh that seems to do the job! And its relatively easy!

As a side point, I’ve had real trouble texturing the “tools” stuff and getting the textures to fit on properly. In the scene they are fine (the sword and the pickaxe), but from having joined them, it would seem i need to move the objects origin to be where the player grabs it to let it swing, however should I move the origin it screws the textures up all over the place, anyone know which options I have to move the objects origin without moving the texture? I think i tried all/most combinations of Coordinates and Projection settings to see what would work and only the current settings do :confused:

Try generated in the texture settings. You may have to shift the offset and size of the textures a bit though.

Yeah I’ve tried that but its screwed up the scale and its impossible to line it up onto the texture now, so that didnt work :confused:

Really? Worked for me… You could just UV map it I guess.