Can you get a 'rendered' view of a model in local view?

I use the local view in Blender a lot, to focus on a certain model and work out the details and texture it and stuff.

I would like to check the ‘final view’ of the model while im local mode. Usually, i press ‘rendered’ view mode in the viewport to do this. But in local mode…there are no lights so I just get a washed out look which doestn help… ANd then it looks like this…which is totally useless

So my question is… is there a way to get that ‘rendered’ look in Local mode? Im working in Blender 2.8.

I don´t think so.
A workaround is to have all you lights on one layer or collection and then simply select your object and the whole light collection and isolate all of that.

Thank you for your reply… too bad it doesnt work like i want it to… but your workaround is a great alternative…

But im running into a problem. Im testing your solution…but i notice when I go into local view for a certain object… and press 3D view: rendered option… It renders out the entire scene (like it would when you’re not in local mode but just in ‘normal’ mode)… But when i do this on another object… it does give me that washed out grey look and stays in local view (like the example I send in my first post)…

What am I doing differently? When does it snap back to normal mode…and when does it stay in that local view when you press rendered view?

And…as a follow up to your solution… You said to create a collection/layer with a light setup on it… and Include that with you object to use it in local view… Is there anyway i can use an HDRI for this? I now how to setup HDRI in the ‘world’…but not on a layer… if thats possible at all…

the fastest solution would be to add a new scene, link the object that you want to render, add lights and world settings, render.

When isolating, did you selet the collection or did you select the object (the lights) within the collection?
You have to do the latter. Select all lights by selecting one and then shift-g -> collection. After that select your object. Now you should have everything selected. Now you can isolate.

As for the HDRI: the HDRI does not get excluded if you isolate an object, so it should not be a problem.

Im doing something wrong… I made a test setup.
Just a cube and a ball and a sun in the scene … and a HDRI

When I click the ball and shift click the sun…i press / to isolate them. This works… (the cube is gone)…

but as soon as i press '3d view: rendered" mode… the cube shows up and it renders out the entire scene… It show the cube, the sun, the ball and the HDRI…

Its like it snaps out of local mode when i enter rendered view mode…

I just tested this and you are right. This happens with Cycles in the current version of 2.80. Not in EEVEE, though.
It is also not the bahvior I now from 2.79.

Perhaps it´s a bug.

Thank you for checking this… Can anybody else confirm this?

Ill post this in the developers forum of Blender, maybe they know weather this is a bug or not

If I now more… I will let you know…

I filed a bug report.

1 Like