Can you hide the particle emitter?

solved

(James Boddie) #1

In 2.79, the particle system for hair allowed you to uncheck Emitter for rendering. I can not find this option in 2.80 alpha. Is there another way to achieve this effect?


(English is not my native language) #2

Not yet for Eevee. I suppose that emitter visibility will be implemented later, in Render item for F12 render image as in Cycles in 2.79, and maybe it will also be useful for eevee (I’m not sure) also in Viewport Display item for Viewport.
But I suppose that a workaround could be to configure a material for emitter with only “Transparent BSDF” shader. Then for that material in Material Tab, select a suitable Blend Mode under Options item mode. You must choose a different material for particles / hair.


(brecht) #3

It’s a bit unintuitive at the moment, but in the Object properties > Duplication panel there are options that control the visibility of duplicators, and this also works for particle emitters.


(English is not my native language) #4

Oh great!. Yes, not intuitive, definitely I would never have looked for it there.


(sanadam) #5

I was looking for it as well, thank you for the tip.


(William) #6

Hmm, yes, this is most certainly not very clear. This location makes it seem like it only applies to the Duplication settings. It’s also invisible by default unless you add some duplication.

We could either add back an option in the Particle settings, or we could relocate the current toggle to Object -> Cycles Settings / Eevee Settings. Then at least it’s clearer that it applies also to particles.


(English is not my native language) #7

For particles obvious place for this configuration would be in Particles settings, an option to show or not show “Emitter” in both, “Render” and “Display” items under Particles tab.
For any other object, I am not sure if it is planned for Eevee to have in Object tab a similar configuration to “Cycles Settings” item. If this is the case and there will be an “Eevee Settings” item, there could be configured visibility of the object for final Render images. And under “Viewport Display” item in Object tab, set visibility in viewport, both Cycles and Eevee. So if you set visibility from Object tab on an object with particles, it would affect the entire object including the particles, not just the emitter.

This is where I would intuitively try to look for options. I could be wrong.


(William) #8

Well, one reason to not have it in the particles settings is that it can conflict. What happens if you have multiple particle systems on an object, where one has Emitter on and another is off - what then? And what if the duplication Emitter display is off, but the particle emitter display is on? Again, there’s a conflict then.

It makes more sense to be a centralised option, because the emitter display can only be one of two things: on or off, even if you have multiple particle systems or if you also use Duplication.


(English is not my native language) #9

I’m a little confused now and I’m not sure if I understood you. Are you referring only to Eevee? Does it generate conflicts currently in Blender 2.79 for Cycles?
I think what I have proposed is how it currently works in Blender 2.79 for Cycles. We have an “Emitter” option under “Render” item per Particles System.
For Eevee the only problem that I have is terminology issues. If we talk about visibility for “Render” as in Cycles, it should only affect “Final Render” results for Eevee, and not “Rendered view”. For Rendered View or Viewport this should always be referred to “Viewport Display” settings.


(burnin) #10

Well, now it really doesn’t work & As it was, it was perfectly fine.

Any off button did turn it off, but control was always there – where & when needed. Surely, while learning (trial&error phase) a couple of mishaps occurred. And yes, there are only two states and just 3 places to check. For particle, lighting & scene direction. Decentralized control saves time, makes a fluent workflow dependent on the specific task at hand and until now i had no issues at all. But now… we have a bug to solve and i’d been given a constant task to always look in to that special centralized place where control holds it’s magnificent power - breaking flow. :stuck_out_tongue: feels as bureaucratic mind control.

& IMHO, it’s counter productive. :face_with_raised_eyebrow:


(j) #11

delete faces, leave vertices, maybe


(William) #12

Well, as I wrote, there were ways in which is was not fine. Because this setting can be on or off, having multiple different settings to control the same thing caused conflicts. Which setting should win out when it’s on in one particle system, but off on another?

It’s really an object setting, not a particle setting.

The current placement of this toggle is not very good either, don’t get me wrong, I’m just explaining why the way it worked in 2.7x didn’t make sense.


(burnin) #13

Oh, nice… it works with today’s build. :smirk:

Anyways, there’s very little sense in Blender itself for the vacant user.
And i must say i never saw any such complaint, at least not from seasoned users. So to whom it didn’t make any sense? From my POV, It is not helping any newcomer, it only damages existent user base.
But who cares…

Next thing: How can old ‘isolate/ influence by layer’ behavior be achieved? Because now, Fields influence Particles on all levels & Collections do nothing. Is it not fully implemented yet or could be
a bug…