Can you reproduce this keyboard BUG on your system?

Hi,

I just discovered a mysterious bug in the BGE.

When I hold a <shift> key and press a number key on numpad (or <,>), the <shift> key is notified as released.

This is a bit of a surprise but might be a driver problem at my system (WinXP, Blender 2.63/2.64).

Can you check on yours?

Here is a test file. Just follow the instructions on screen:

  • press and hold <left shift>
  • press <numpad 0>

Please post your result

Thanks
Monster

Attachments

KeyboardBug.blend (400 KB)

Huh, that’s odd. This is a bug that arises for me as well, if you press and hold shift and press num-pad 0. Odd.

Hi SolarLune,
what OS are you using?

hey monster, tried it out for u asswell and found the bug.

At first time that i opened it has the bug and test failed.
looked at bricks then tried again and bug still there.
Then closed the blend restarted it and tested it a few times again and still the bug is there

I have no idea why but lol funny bug. I am using win 8 with blender 2.65

Then i tried something else:
To solve the bug u have, simply turn off numlock and the bug is gone and your script will pass.

@Monster - I’m using Windows 7 64-bit with a 32-bit build of Blender.

Test failed here

OS: Win 7 64 Bits
Blender 2.65a 32 bits

Pass - Mint 13 / 2.64a
Pass - wine 1.5 / 2.65a
Fail - XP32 vm / 2.64

Hrm… Since according to pqftgs’s tests it’s also Linux, maybe it’s a keyboard driver problem. Maybe it’s even a keyboard limitation problem, like how you can only press a certain number of keys at a time (4 or so, if I’m correct).

I don’t see a bug on Windows 7 Ultimate 64bit. Your scene reports ‘passed’ and the zero does not change to a one.

Aha, if I run the same scene with NumLock enabled it does fail and the zero turns to a one.

Passed
Win 7 - 64 bit
Blender 2.63 - 32 bit

Thanks blenderheads,

this is very useful information. If anybody is using MacOs and test there it would be nice. Right now it looks like a Windows/WindowsDriver problem.

Interesting to see it does not happen when Num is disabled.

If it really is a OS issue, there is not really much the BGE can do. So it is good to know about that. Luckily the number block is usually not used with alternative layout (shift).