Cannot add keyframes to NLA Strip 'Evaluation' fields.

In Blender 2.75a, I have been tryihg to use the new way of controlling Evaluation’s ‘Animated Influence’ and ‘Animated Strip TIme’. You tick them and they turn green, but when I try to add a keyframe an error box says ‘No F-Curve to add keyframe to’. This occurs both outside and inside of tweak mode. So basically I cannot animate influence or Strip Time :frowning:

Please help! Thanks.

Hmm… that’s strange. Could you provide some more detailed steps of how exactly you’re trying to do this?

Does this happen on all files, a fresh setup, or only on old files (e.g. perhaps those where you’ve keyframed this stuff in an older version of Blender)?

Open up a start scene with a cube.

  • Keyframe the cube’s location on frame1.
  • Move playhead to anywhere else along the timeline, move the cube, add another keyframe so the cube has basic movement.
  • On the NLA Editor, collapse the temporary orange strip into a proper NLA strip.
  • Tick ‘Animated Strip Time’ - it automatically becomes green on the ‘Strip Time’ numeric field.
  • Hover mouse over ‘Strip Time’ numeric field and try adding a keyframe and the abovementioned error box comes up.
  • Tab into Strip’s Tweak Mode, try step 5 again, and same error occurs.

In step 5, how are you inserting the keyframe?

Here, everything works perfectly fine no matter how I do it.

I hover over the numeric field for Strip TIme and press the key ‘i’.

After some more testing, I think I’ve found a case where this can happen. Just to confirm, do you have “Only Insert Needed” or “Visual keying” enabled?

hello , I had the same problem .
I solved it by creating a keyframe in the graph editor . I think that in the slider can not be made a

The problem should now be fixed in the latest builds -