Cannot delete keyframes

I’m running blender 2.62. In the 3D View with timeline showing I can add key frames but cannot delete them. When in the Graph Editor neither the menu selection KEY> DELETE KEY FRAMES nor its shortcut “X” does anything. “Alt-i” in both views is equally unresponsive. In desperation I went to the NLA Editor and played around – don’t know what I did – but then when I came back to the Graph Editor the Key frames were gone. Good right? No, because the animation played exactly the same w/o any key frames showing. Any suggestions?

I’m not sure what’s happened in the NLA. My guess is you made your default action into an action strip. If that’s the case, you can delete the strip in the NLA and the animation should go away.

But back to your original problem, it’s hard to diagnose. Simple questions first:

  • in the 3d view are do you have the object selected when you are trying to delete the keys?
  • in the graph editor, do you have keyframes selected? What happens exactly when you border select some keys and press X?

Hi freen. Yes, the object (text that I am animating ) is selected in object mode. I made a mistake on a keyframe so in the 3D view I attempted to delete that keyframe by placing the timeline frame selector on the keyframe and using "X’ and/or “alt+i”. That did not work so I went to the Graph editor and selected ( shft+RMB ) the appropriate keyframe and made the same presses – to no avail. Also tried to delete all the keyframes: KEY>DELETE KEYFRAMES with no result.

Somehow in the NLA editor I was able to delete all the keyframes but now I have the animation ( with “mistake” ) and no keyframes showing. Weird. I don’t really care about the blend file; I can easily start over. But not being able to recover from a keyframe mistake has me perplexed.

OK, I had inadvertently created an NLA strip so I deleted that and, yes, that solved the “animation w/o keyframe” problem. Still don’t know why I cannot delete a keyframe, though.

The easiest way to delete key frames is to go in the Dopesheet, switch the mode to “Action Editor”. There simply scroll over the keyframes then you delete them the same way you delete a cube in the viewport.

Kalinaki, that is way too easy. Are you trying to spoil me? I’m a blender noob. Give me something really difficult to do – I expect it. Thank you.

Freen, thank you for the heads up about creating that NLA strip. It was totally inadvertent but that was exactly what happened. I learned two cool things today.

Thanks from this newbie, too.