Cannot properly select edges in Edit mode on Chromebook with Linux

Hello! I am using Blender 3 on a Pixelbook Chromebook with Linux mode.
I cannot properly select edges in edit mode, i tried to upload a short video to show you but I cant upload as i am a new user…
I found a similar issue on the web, someone said about the display drivers being outdated?
However, the display and anti-aliasing works fine for me. In fact everything else seems fine except edge selection.
I think my graphics adapter is Intel HD Graphics 615.

Did you check the compatibility page referenced at the developer site:

Does this help:

What exactly is happening when you try to select… Is it selecting the wrong edge, can you see the edge, is it not selecting at all, can you select verts or faces?

Its selecting the wrong edge, actuallly it seems that it randomly selects one of the horizontal edges and ignoring the vertical ones. I tried this with the initial cube and with a cylinder. Even if i rotate the objects, the same group of edges that were horizontal are randomly selected.
Yes, i works fine when selecting verts and faces.

I just found this. I will try with changing those settings and see how it goes…

Hi, Have you tried other selection tool?:

Yes, same issue swith all tools. With Lasso tool is even weirder if i select everthing it totaly ignores the vertical edges but it will select horizontal faces too even though i am in Edge mode.

Did you try updating the driver?

Did you try running from a console, you may get an error message?

Yes actually i am running it on Snaps, Debian and I do get an error at startup.
Probably this explains why there are these errors.

Read prefs: /home/constantinecozma/.config/blender/3.0/config/userpref.blend
Warning: Could not find a matching GPU name. Things may not behave as expected.
Detected OpenGL configuration:
Vendor: Red Hat
Renderer: virgl

Not sure how to update the display driver ? I am using Chrome OS with Linux mode so i think the Linux is updated with Chrome OS ? I am running latest Chrome OS.

Why using virgl renderer? Default for mesa driver should work without problem.
Try to look at mesa packages available.

A couple things:

On the snap page for blender, it only has amd listed as the graphics card so you may have to do something different.

Also you could try the previous versions of blender to see if the same thing happens.

Is this debian itself or is it ubuntu or something?

I am using Debian :

PRETTY_NAME=“Debian GNU/Linux 10 (buster)”
NAME=“Debian GNU/Linux”
VERSION=“10 (buster)”

Maybe I need to install it directly from
Not sure i want to mess with the display drivers. I am usually not using Linux and dont know much about it.
I dont remember if I had this issue on the 2.9 previous version. It is possible that i didn`t.

It looks like i do have Mesa drivers. Here are some samples from the info report about the GPU :

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Canvas out-of-process rasterization: Disabled
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Hardware accelerated
  • OpenGL: Enabled
  • Rasterization: Hardware accelerated
  • Raw Draw: Disabled
  • Skia Renderer: Disabled
  • Video Decode: Hardware accelerated
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Driver Information

Initialization time 41
In-process GPU false
Passthrough Command Decoder false
Sandboxed true
GPU0 VENDOR= 0x8086 [Intel Open Source Technology Center], DEVICE=0x591e [Mesa DRI Intel(R) HD Graphics 615 (KBL GT2)], REV=2 ACTIVE
Optimus false
AMD switchable false
Driver vendor Mesa
Driver version 21.1.5
GPU CUDA compute capability major version 0
Pixel shader version 3.20
Vertex shader version 3.20
Max. MSAA samples 16
Machine model name
Machine model version
GL_VENDOR Intel Open Source Technology Center
GL_RENDERER Mesa DRI Intel(R) HD Graphics 615 (KBL GT2)
GL_VERSION OpenGL ES 3.2 Mesa 21.1.5 (git-997a5e6227)

I also found this warning on the report , not sure if its relevant.

Problems Detected

  • Mesa drivers in ChromeOS handle varyings without static use incorrectly: [
    Applied Workarounds: count_all_in_varyings_packing

But the question is why is it using virgl renderer when my machine reports that i have Mesa renderer :

GL_VENDOR Intel Open Source Technology Center
GL_RENDERER Mesa DRI Intel(R) HD Graphics 615 (KBL GT2)
GL_VERSION OpenGL ES 3.2 Mesa 21.1.5 (git-997a5e6227)

Could it be because of the way it is installed with the snap version?
Looks like Virgil is using a virtual GPU. Maybe its the default renderer for Linux inside Chrome OS?

Hardware Requirements

  • 64-bit quad core CPU with SSE2 support
  • 8 GB RAM
  • Full HD display
  • Mouse, trackpad or pen+tablet
  • Graphics card with 2 GB RAM, OpenGL 4.3
  • Less than 10 year old

I think this (you have OpenGL 3.2 and you need 4.3) is your problem, from what I can tell on this site (, virgl (just v-i-r-g-l) is a project from mesa.

This line under OpenGL is what you want, I think.

virgl 	(96.2%) 154 	4.3

Although I think its more likely that a solution can be found by upgrading debian to bullseye, because IIRC the glibc version is important to get the opengl version to work.

I think I would recommend taking this up with the debian folks.

I run opensuse and I had to upgrade to a more programmer friendly version to get I think it was 2.8 to work at all with my nvidia graphics card.

Thanks for the advice! It is probably whats causing these issues.
I have found this question here on a Google page regarding OpenGL upgrade

Unfortunately i have no ideea which package is compatible with my machine and also how can I install it?

My CPU is Intel(R) Core™ i5-7Y57 , at 1.20 ghz 64 BIT dual core
Would this package be good for an update?

Also, for my processor do i need to install the AMD64 version?

I tried to install another package manager like Synaptic and Aptitude as it is recommended to handle the opengl update but i cannot install neither of them. It asks for some other dependencies. Is it because i am using a Snap and its not compatible with those two?
This is getting so complicated.
Can i make the update through Snaps?

My first question is, how did you get debian on the Chromebook?

Another thought is, have you tried previous versions of blender from snap?

Why do you want 3.0? Geometry Nodes?

Unfortunately i have no ideea which package is compatible with my machine and also how can I install it?

It can be very confusing.

Debian is the oficial Linux which comes in a container inside Chrome OS and is the oficial version that comes with every Chromebook.
Yes i am especially into Geometry Nodes.

Maybe the best solution temporarily is to just use it as is, that is without edge selection, and use vert and face selection instead.

Meanwhile you can further investigate whether OpenGL, and GlibC have anything to do with your problem. If that is the case I think you may benefit from upgrading to debian bullseye.

I don’t have experience with containers. If you want upgrade to bullseye. This may be a clue how to get you there.

I can’t seem to find much information about the actual OS in the container at the chrome site, but I think that may help.

Yes for now i am ok with the situation. I do have a Windows laptop that I use for more serious work and I keep the Chromebook for learning and experimenting.