Cannot remove normal edge splits in Blender 2.71 when exporting to obj

Hello,

First post here on the forums. I’ve been using blender for about 2 years now, and I’m super pleased about the recent addition of proper maya-like smoothing groups. It was pretty simple to get edge splits working the way I wanted them, I highlighted the edges I wanted to harden and chose the “sharp” button in the shading area of the tools sidebar. The model preview did not update in the viewport, and continued to look unsharpened (save for the blue highlights in edit mode showing me that they were indeed split,) and when I exported the .obj and imported into marmoset, the proper splits were there, with no separate meshes (perfect!) Next I wanted to do a bit of tweaking, and so I went back to blender and unsharpened some edges. The blue highlight disappeared, but when I exported to .obj again, the same splits remained. I then selected the whole mesh, and hit “smooth” in the face, edge, and vertex option. Still no results, the mesh exported with edge splits. I checked to make sure there was no separated geometry, and that I was exporting the mesh I had selected, and everything checked out, no duplicate verts. I don’t know what to do at this point, I really don’t want to go back to editing normals in maya and exporting back and forth, it’s slow as heck. If someone could shed some light on what I might be doing wrong, that would be great. I’ll post some screenshots if that would help.

Many thanks,

Taytahs

Could be a bug. You should contact mont29, the dev who is/was working on normal edge split editing.

I`m not sure how one contacts Blender devs, but here are some pointers:


http://wiki.blender.org/index.php/User:Mont29/Foundation

Please supply an example blend file that shows this effect