Cannot render multiple layers


(CurtisS) #1

Is anyone having problems getting ANYTHING to render on any layer except layer 1? I have objects on several layers but only layer 1 shows up in the render. I checked all of the usual material and edit buttons that might affect this but nothing helps.

This could be a bug in 2.25 as I never had a problem like this in 2.23…or… a new feature was added that I am not aware of. I don’t recall anyone mentioning it in any forum and I don’t see how anyone could miss this problem.

Hopefully it is just something I missed as it is driving me crazy. :x


(Dittohead) #2

you don’t have those layers selected, hit th tilde key or shift-select all the other layers that have objects on them.


(BgDM) #3

Actually, I had this happen to me for the very first time the other day in 2.23. I did a radiosity calc and then rendered and a few of my layers were gone in the render. I can’t explain it either. Never happened before.

I had all of my layers on as well. So go figure.

BgDM


(CurtisS) #4

Like I said, I’ve tried all of the things that would normally affect rendering in layers including making sure all layers were selected in all view ports. I even thought that maybe the camera itself needed to have all of the layer buttons enabled in the Edit buttons but that did not help either. I just might go back to 2.23 andtry it. This is quite baffling.


(CurtisS) #5

Well, I just tried 2.23 and the render was fine and rendered all layers. It was ALOT faster rendering as well. I’m going back to 2.23 for now. I can’t work with that layer problem in 2.25 (though I am going to see if the same problem occurs on my Mac at home using 2.25).


(ilac) #6

Strange, I’ve been using publisher 2.25 (windows) for several months now and never encountered this problem :o

Does it also do it if you start afresh in a new file or is it specific to this particular file?


(VelikM) #7

It sounds like you have the ‘Layer’ button selected in the Lamp buttons window for your lighting. If the Layer button is selected the light only lights the layer it’s on. Thats the only way I can reproduce your problem. Publisher 2.25 beta OS X


(CurtisS) #8

Strange? Yes, indeed. It caught me by surprise when I first started using 2.25. At first, I thought it was me just forgetting some setting somewhere in the materials or lamps buttons but I have been using Blender long enough to know better. I have yet to try it on my Mac but it is very strange that the problem does not occur in 2.23 on the same PC.

It has this problem with any file I open including old ones or new ones. It could be something with my PC I suppose since no one else seems to be experiencing it. :frowning:


(CurtisS) #9

Hi everyone,
I thought I would revisit this old post with an update…

…the problem was that 2.23 and 2.25 seem to treat the camera view locking differently. This is in reference to the little padlock button that is next to the layer buttons in the viewport. Once I toggled the Lock button with the all the layers selected, all the layers rendered.

So, I fell into a little trap that baffled me for a couple of weeks. Anyhow, justa “heads up” so no one else runs into this problem.