Cannot Render w/Transparent Background

This file is producing an mp4 video with a black background. I would like for it to be transparent. I thought I had checked “all the boxes”, such as transparent, etc. Also, I used the PNG format, but I cannot locate a codec for render with RGBA option? Would someone be so kind as to tell me where I’m going wrong?!

LATER: Discovered the FFmpeg video codec #1 (new to me) that provides the RGBA for transparency; however, the background is now a “noisey” looking gray??!!