Cannot select anything in solid mode

What’s going on?

I have been using blender without problems for ages and now all of a sudden I can not longer select anything unless I am in wireframe mode. Have I changed a setting somewhere?

I tried using 2.54, 2.55 and 2.56, It worked properly yesterday. I can even select the vertices on the default cube (or the edges and faces)

Using the circle select or box select doesn’t work either selecting all with ‘a’ works

The display looks a bit funny too, with kind of fuzzy edges.

Using OpenSUSE11.2

Gunna try a reboot

Just an update on this, 2.48 has the same problem.

If I turn of background occlusion in any blender version , it works fine also

Tried a system reboot, same problem.

Tried some different screen resolutions, same problem

I haven’t made any system changes so I’m a bit stumped here.

Okay, nevermind.

I changes the graphics setting on my workstation to 16 bit color (Instead of 24) because I read somewhere that it make Blender go faster, but it only took effect when I happened to reboot yesterday.

Seems that I cannot select stuff in solid mode in 16 bit color, it needs to be 24 bit.

Nothing like talking to yourself on a forum though. Next I’ll be telling myself some jokes haha