Cannot Select Individual Bones in Weight Paint Mode

I have been trying for the past week to fix this issue, but nothing has worked and my final option is to make a new post on forums asking for help. I cannot select a specific bone in weight paint mode, it selects the whole armature instead. I have tried every combination of shift, alt, and ctrl click I can possibly do. I have looked at countless other forum posts that say to go between pose and object mode then weight paint or other fixes, but nothing has worked. I have tried everything and am getting very frustrated, especially when I asked a friend to stream her screen and she did it just by shift clicking a bone. I don’t know if it’s something in my blender settings (I looked very hard, trust me) but something is wrong with my blender, even after a new installation of multiple different versions. Any help would be appreciated greatly.

HI, i am not sure what you are trying to do, but in weight painting mode you select the bone vertex group in order to paint not the bone itself: