Can't activate RULER ad-on.

I just downloaded Blender 2.53 (trunk) rev31626. The RULER ad-on is installed but can’t be activated, any idea why not?

Actually, I did activate it just after the download and it worked properly. I didn’t save before closing blender and after reopening blender the ruler won’t activate.

d2

got same problem

but go to the N transform panel and click on the activate ruler

it works fine now

don’t know why the Shift-ctrl- R does not work anymore !

salutations

“activate ruler” isn’t in my transform panel.

d2

did you check at the bottom of N panel!

i tested it in ver 31626

and after clicking i got the ruler again

but not with the shift Crl R keys sequence
don’t know why it’s not working ?

salutations

[quote=RickyBlender;1692362]did you check at the bottom of N panel! /quote]

Yes, the RULER option showed up at the bottom of the N panel the first time I enabled it, but it has now disappeared from the N panel completely.

RULER is also not listed in User Preferences/Addon.

It is still in the Scripts/Addons folder.

d2

some flukes may be !

try to re install it and see what happen!

i know mine is working fine on vista 32 bits !

but not the Ctrl-shit R keys !
just tested it again
in n panel the enable and disable are working ok !

i just wish this would also give the angle between 2 points for line
that would be more wsome !

happy 2.5

salutations

It says it is already installed.

d2

delete all the folders exept the zip file

then re extract it

then it will work ok i guess

happy 2.5

I did a fresh compilation with SVN 31638 but no ruler addon to be seen?
(Windows 32 version) (it seems to be committed but not yet available, to be downloadable?)

it’s a script addon available in 626
you can get from that version i guess !

hope it makes it as an addon but would like to see the lenght and angles for lines 2 and 3D too!

would be eve more powerfull and faster to get

happy 2.5

I do not like old versions :wink: (there must be a reason, why it is not included anymore in the state of 31626)

The ruler is working again after re-extracting and saving. After taking a closer look at it, I don’t see any reason why I might want to use it, so I disabled it.

I just now tried to enable it again and it doesn’t work. I think there is something wrong with the script.

Disable your ruler then Save User Settings, close and reopen blender. Try to re-enable the ruler and see what happens.

What is the ruler’s purpose as it is designed in this script?

d2

the ruler is just there to show the location of the cursor
which is good for doing mechanical design
but not for eveybody agreed!

but as i said i would like to see it with some angle indications
often i like to add a line at a certain angle like 36 degrees but cannot do it in blender
so if the angle was shown then i would be able to spec an angle precisely i guess
if possible to add it on keyboard
may be one day someone will come up with that effect !

happy 2.5