Can't animate objects seperately.

My apologies if this is a ‘newbie’ issue…Ok, I’ve run into a frustrating issue that I’m hoping will become one of those ‘ah-ha’ moments. I’ve created a logo containing 8 separate objects with a mirror modifier. Once the mirror is applied there are a total of 15 objects since the one in the middle became one. I’m trying to animate each piece separately so the logo builds over time. I went into ‘edit’ mode, selected just the mirrored halves of each object (one at a time) and used the ‘separate’ command. I then ‘keyed’ (selecting ‘I’, then ‘LocRotScale’) all of the objects into position on frame one. I went a few frames more, drug the first object to be animated to the spot I wanted, then ‘keyed’ its position.
Here’s when the trouble starts. As soon as I select another frame all of the objects, left behind on frame one, snap to the position of the object I just moved. After that all of the objects move as one.
I’ve tried to duplicating the whole logo, for each of 15 objects, then going in and deleting all objects except one for each of different instances. Still the same result.
I ensured that the ‘ME’ and ‘OB’ names were original to each object, rebooted the computer, saved-closed-reopened the file and Blender, and even started again from scratch. I’ve spent a few days reading and reading, but I’ve got to be missing the answer. I truly hope that it’s something simple :slight_smile:

Select one of the other items (one you did not intend to move) and look at the IPO window. It most likely has the IPO from the other item already associated with it. Simply click the X next to the IPO data block name.

I revealed every layer, selected all objects, and then went down every menu, in the IPO window, selecting ‘A’, ‘X’, then ‘Erase Selected Objects’. Even did that in NLA and Action window for good measure. Still the problem persists.

I wasn’t referring to the actual IPO curves, but instead the data block. At the bottom right of the IPO window is a drop-down list with a thumbtack icon. It will have a data block name like IP:OBIPO. This is what you want to delete using the X to the right of the data block name.

That did it; you’re worth your weight in gold :slight_smile: It took me a bit to get a handle on the concept, but I think I got it now. There’s a lot of information out there for Blender, and that can be a problem when one doesn’t even know how to ask the right question…information overload. It’s people like you that have the incredible patience to help others that makes all the difference in the world. Thanks again!

Glad that helped. That little data block list is not the easiest thing to explain. Indeed you can get overloaded with information on blender. Just take it a step at a time and as you allready did, don’t be afraid to ask for help.

Keep Blending!