Can't build blender

I am trying to build the fluid-mantaflow branch of blender on Linux Mint 18 and keep running into errors.

CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find PythonLibsUnix (missing: PYTHON_LIBRARY PYTHON_LIBPATH
PYTHON_INCLUDE_DIR PYTHON_INCLUDE_CONFIG_DIR)
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
build_files/cmake/Modules/FindPythonLibsUnix.cmake:181 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
build_files/cmake/platform/platform_unix.cmake:75 (find_package)
CMakeLists.txt:894 (include)

I have done a bunch of research and cant seem to find a package that will fix it…
Thanks!

Hi, can you build master?
May you add your question to the mantaflow thread too.
If you cant build master too you can get help at #blendercoders at freenode.net.

Cheers, mib