Can't compile SVN under Win32 (mingw+Scons)

I used to be able to compile SVN trunk just fine. Today I updated SVN folder and when I tried compiling it, I got following error:

C:\build\blender>scons BF_TOOLSET=mingw BF_BUILDDIR=c:\install -j2
scons: Reading SConscript files …
ImportError: No module named Variables:
File “C:\build\blender\SConstruct”, line 42:
import tools.btools
File “C:\build\blender ools\btools.py”, line 6:
import SCons.Variables
C:\build\blender>

How to fix that?

Thank you.

The minimum version of scons has changed.
Uninstall your old scons first, then install the latest version of Scons.


The new Scons puts its launcher batch in Python25\Scripts rather than in the base python directory, so you have to update your environment variables and restart to be able to use scons from the command line.

I have wrestled with compiling Blender for the last couple weeks, so if you come across any other problems, I might be able help. :wink:

for build
python scons/scons.py BF_TOOLSET=mingw -j2
for clean
python scons/scons.py clean BF_TOOLSET=mingw

I followed advice that you both gave me and now I get this:

C:\build\blender>python scons/scons.py BF_TOOLSET=mingw -j2 BF_BUILDDIR=c:\insta
ll -j2
scons: Reading SConscript files …
Command-line arguments
BF_TOOLSET = mingw
BF_BUILDDIR = c:\install
Command-line targets
No targets given, using default
Using mingw
Using config file: config\win32-mingw-config.py
Using user-config file: user-config.py
Build with 2 parallel jobs
Building in c:\install
Configuring library bf_soundsystem
Configuring library bf_string
Configuring library bf_ghost
Configuring library bf_guardedalloc
Configuring library bf_bmfont
Configuring library bf_moto
Configuring library blender_CTR
Configuring library bf_memutil
Configuring library bf_decimation
Configuring library bf_IK
Configuring library blender_bop
Configuring library blender_ONL
Configuring library bf_elbeem
Configuring library blender_BSP
Configuring library extern_glew
Configuring library extern_qhull
Configuring library extern_solid
Configuring library extern_bullet2linmath
Configuring library extern_bullet2dynamics
Configuring library extern_bullet2collision_broadphase
Configuring library extern_bullet2collision_dispatch
Configuring library extern_bullet2collision_gimpact
Configuring library extern_bullet2collision_shapes
Configuring library extern_bullet2collision_narrowphase
Configuring library extern_bullet2softbody
Configuring library extern_ftgl
Configuring library verse
Configuring program verse
TypeError: File C:\build\blender\install found where directory expected.:
File “C:\build\blender\SConstruct”, line 365:
SConscript(B.root_build_dir+’/extern/SConscript’)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Script\SConscript.py”, li
ne 599:
return apply(method, args, kw)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Script\SConscript.py”, li
ne 536:
return apply(_SConscript, [self.fs,] + files, subst_kw)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Script\SConscript.py”, li
ne 259:
exec file in call_stack[-1].globals
File “C:\build\blender\extern\SConscript”, line 18:
SConscript([‘verse/dist/SConstruct’])
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Script\SConscript.py”, li
ne 599:
return apply(method, args, kw)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Script\SConscript.py”, li
ne 536:
return apply(_SConscript, [self.fs,] + files, subst_kw)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Script\SConscript.py”, li
ne 259:
exec file in call_stack[-1].globals
File “C:\build\blender\extern\verse\dist\SConstruct”, line 144:
libpath=’#’+env[‘BF_BUILDDIR’]+’/lib’)
File “C:\build\blender ools\Blender.py”, line 488:
prog = lenv.Program(target=builddir+‘bin/’+progname, source=sources)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Environment.py”, line 219
:
return apply(MethodWrapper.call, (self, target, source) + args, kw)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Environment.py”, line 183
:
return apply(self.method, nargs, kwargs)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Builder.py”, line 614:
return self._execute(env, target, source, OverrideWarner(kw), ekw)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Builder.py”, line 561:
tlist, slist = self._create_nodes(env, target, source)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Builder.py”, line 508:
tlist = env.arg2nodes(target, target_factory, target=target, source=source)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Environment.py”, line 438
:
v = node_factory(apply(self.subst, (v,), kw))
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 1192:
return self._lookup(name, directory, File, create)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 1171:
return root._lookup_abs(p, fsclass, create)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 2015:
dir_node = self._lookup_abs(dir_name, Dir)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 2015:
dir_node = self._lookup_abs(dir_name, Dir)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 2020:
result.diskcheck_match()
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 1334:
“File %s found where directory expected.”)
File “C:\build\blender\scons\scons-local-1.1.0\SCons\Node\FS.py”, line 343:
raise TypeError, errorfmt % node.abspath

C:\build\blender>

I haven’t tried using the local scons (included with Blender), which is what samas was referring to.

Try installing scons for yourself.

I did. I installed it, put it in the environmental variables, and I still get the same error as I posted at the beginning.
I totally hate it :slight_smile:

Ok. I re-installed Python and Scons, I do regular compile and I get the same error as if I would use local Scons :confused:

nm. I installed Python 2.6 and used following in command line: python scons/scons.py BF_TOOLSET=mingw