Can't composite image (compositor stuck at 0%)

I’ve rendered an image to an .exr file. Then I loaded the .exr files into the compositor and began compositing. When I was finished, I saved and removed the composition borders (CTL + ALt + B).

Up to this point, blender had no difficulties displaying my image, with a latency of about 30 seconds (it’s okay, considering that it is a 100MB .exr file). But then the trouble began, when I accidently unchecked “Backdrop” (silly me).
When I checked it again, Blender took about 45 minutes to get the picture to display again.

I added a slight blur to the glossy paths to get rid of fireflies and minor pixel errors. Blender stuck at 0% Compositing, waited for five or ten minutes for something to happen. I stopped the compositing and added a File Output node, set the type to PNG.

In my render settings, I checked “Compositor”, and hit render. What I expected Blender to do is to get the .exr, composite it and the output it. I forgot to set the type of output to PNG. Blender didn’t render an image, stuck at 0% render - but strangely produced an “render_00016.png.exr”, which doesn’t contain anything. I stopped the rendering process.

Blender refuses to composite my image. I am left with an uncomposited .exr file and of course, the .blend file. I someone can somehow composite my image or show me what I did wrong, I’d be very glad.

Here is the .blend file (textures not included, it’s just about the compositor):
Here is the .exr file (rendered it for 10 hrs, so don’t hit render in the blend file without checking the compositor. Of course, you’ll have to adjust the filepath):

Thanks in advance.

Thank you very much!

If you’re going to append Solved to the title at least write how it was solved. For the benefit of others.

That was my problem. I do not know how it was solved. I guess I just have a crappy computer.

It was solved by pressing the Render button and waiting seven minutes for it to finish rendering